Can't edit flow, leading to white screen

  • 15 February 2021
  • 20 replies

Badge +2

Hello guys,


Can someone help please, I cannot edit a flow for some reason. whenever I click on the welcome series flow it goes to a white screen. How to fix this?



Thanks in advance!






Best answer by Bobi N. 16 February 2021, 10:11

View original

20 replies

Userlevel 6
Badge +34


This sounds to me more like temporary loading error which should be fixed on its own.. but just for any case to mention if this is not your personal account to edit flows make sure you have Admin access.. other way you won’t be able to edit flows.

Badge +2


This sounds to me more like temporary loading error which should be fixed on its own.. but just for any case to mention if this is not your personal account to edit flows make sure you have Admin access.. other way you won’t be able to edit flows.

thanks! that was the problem indeed, I recreated it completely and it didn’t have any problems after that, thank you :)


I am still having this problem and no matter what I do (I even tried to add another user as ADMIN) and tried to access the form from another completely separate computer. The form is in perpetual EDITING mode and will not let me make any changes to it or edit it. I keep getting a white blank screen on my browser every time i try to edit. Please help!

Userlevel 7
Badge +57

Hi there @pinoferre,

To rule out any browser related issues, please try accessing the flow creation page from an incognito window (Chrome) or private window (Safari or Firefox) or using a different browser from what you are currently using. Additionally, can you please try clearing your cache or hard refreshing your browser. If you are using a VPN, this is also known to cause issues. 


Are you getting other errors that popup and can you provide some screenshots of what you are seeing and where exactly you are experiencing issues?
Additionally, I am not seeing anything pop up on our status page. So this could be a temporary issue as well depending on how long you have experienced this.







Hi. Yes I tried all that. Even tried going in from a completely different computer. The only solution was to recreate the Form and delete the old one. Hopefully it doesn't happen again. Thanks for your help!!

Userlevel 7
Badge +57

Apologies to hear that @pinoferre, I’ll definitely look into this more and provide this feedback to the respective team.


All the best,



same issue here allll day today 

Userlevel 7
Badge +57


Can you confirm the browser you are using, and if possible to try opening the flow when logged into a different browser than the one you normally use, or in a private browsing session if that is not possible. Can you also confirm here that you have tried previous mentioned troubleshooting steps in this thread? This way we can further pinpoint what might be going on.


Thank you,



I’m having the same issue, and it’s annoying. I’ve tried all different browsers and incognito. It works w/ a new browser until the first time I click “DONE” for the flow. And then blank screen. Super annoying. 

Let me know if you want to troubleshoot together. 


Badge +4

Same thing has been happening on and off for the last two days. Some flows will open while others won’t.  Right now none of them are opening, just a white screen.

got the same problem...

I have access to literally everything, except when I go to review/schedule, I get this white screen of doom.  Oddly enough though, when I go back to the main campaigns screen, even though I have recently made edits, that is not reflected in the last edited date, even though the edits saved.  I have tried clearing cache and cookies, Incognito mode, an entirely different browser, signing in and out, and nothing is fixing this.  I’m about to try cloning and see if that works.  I hope it works, but that would also be pretty irritating to have to do that as a fix.

Update: Cloning the campaign does not work to get past this error.

Update: Issue seems to have fixed itself.

same white screen issue when trying to schedule an email 

How is this issue not fixed over 1yr after first reported?

Not only flows are leading to white screen, now “support” site is also dead.

Is anybody on your dev team handling this please?

Same issue here when trying to schedule an email. Additionally, clicking the Support tab goes to a white screen of death as well.


Occurring on multiple browsers, no ad-blockers or VPN.

Same issue here. Im trying to send a campaign and when clicking the review -button, there is only a blank white screen. I have tried everything that others have also tried above and nothing works, the same blank white screen is still there. 


EDIT : now it just started to work again. 

Userlevel 7
Badge +57

An earlier release caused an error when trying to load certain pages in Klaviyo, and this has since been rolled back.  Please try accessing the page in Klaviyo where you were seeing a blank page again, and if you still see a blank page please let us know

Badge +4

It’s been happening again today intermittently. Difficult to complete building a flow when you can’t get to it.

I’ve been getting this error all week. Have tried clearing cache, refreshing browser window, signing in + out, etc. Not working. 

I can go from the dashboard to the list of flows, but when I try to click into a flow to edit it, it just goes to a white screen. 

Need to get in + be able to use this functionality — can you please advise on when this will be resolved? Thank you. 

Userlevel 7
Badge +57

Hello @ashleyjoggy @Jhall ,

I would highly recommend contacting support and providing your browser’s dev console in a screenshot so that they can troubleshoot your account internally and look into it.