Back in stock is not working in cospora theme

  • 30 March 2022
  • 1 reply
  • 14 views

Badge +1

My “back in stock” flow is not working. I follow these steps:

  1. Create a “back in stock” flow in the backend
  2. Write the code in theme.liquid 
  3. Add private API key in code.
  4. I am also following these steps with my other store with “superstore” theme. There it is working fine.

1 reply

Userlevel 6
Badge +51

Hi@Sushma

 

Welcome to the Community! Sorry to hear your experiencing difficulty creating your Back in Stock flow here, would love to help! 

 

First, can you confirm that you have your ‘Viewed Product’ and ‘Added to Cart’ features installed in your cospora theme store? Along with setting up your Back in Stock Flow in your Klaviyo account, our documentation walks you through  everything you need to set up before you install the BIS snippet.  

 

The Next Steps are outlined 

  1. From your Shopify Admin click Online Store > Themes.
  2. Click your theme’s Actions dropdown and select Edit Code.
  3. Search for the theme.liquid file, and click to open it in the editor.
  4. Copy the JavaScript snippet and paste it into your theme.liquid file directly above the </body> tag. 

 

However, as step #5 states in the Help Center Article, you should be adding your public API key into the snippet, not your private API key. Finally, can you ensure that you pasted the snippet in the proper place, right above the the </body> tag and clicked save? Additionally, I would go through the code again to ensure there isn’t an extra/missing letter or space, as even something as simple as that can render the code ineffective. 

 

Hope this helps! Thank you for participating in the Community! 

-Taylor 

Reply