Solved

Browse Abandonment - Not displaying VAT (WooComm)

  • 20 October 2021
  • 3 replies
  • 25 views

Badge
  • New Member
  • 0 replies

Hello,

The product price in the browse abandoned cart emails is without vat, i need to display price including vat, what should i change in this line here?

 

{% currency_format event.Metadata.Price|floatformat:2|striptags %}

icon

Best answer by david.to 20 October 2021, 20:01

View original

3 replies

Userlevel 6
Badge +5

Hello @APC,

Thanks for being a part of the Klaviyo Community!

If you were using any of the default ecommerce integration with Klaviyo such as Shopify, WooCommerce, BigCommerce, or Magento, the Viewed Product event data that is synced from these platforms to Klaviyo is actually populated from the details available from your own product catalog used to populate the product page. If the price that is synced from your product catalog as the metadata used for the Viewed Product is not accurate, I would suggest adjusting this within your own catalog backend to reflect the price accurately. 

Alternatively, if you wish to include more data points or more metadata fields that would be shared as part of the Viewed Product event, then instead of leveraging the default Viewed Product metric, I would recommend custom coding your own Viewed Product event. Custom coding your own event/metric will allow you more flexibility in what sort of information gets shared to Klaviyo. You can custom code your own events by leveraging Klaviyo’s API as mentioned in the following Help Center articles: 

Since this process requires custom coding, for further assistance in creating this custom event, I would recommend working with a developer or finding a Klaviyo partner who can further help you implement this. 

Another option you have if your VAT is a set amount would be using and incorporating the |add: variable filter as part of your syntax. For example if the variable returns a 10, using {{ your_variable|add:2|floatformat:2 }} would return 12.00 as the example syntax would be adding 2 to the variable while also including the two decimal points per the floatformat filter. You can learn more about using variable filters and also see a list of them from the Glossary of Variable Filters and Using Filters to Customize Template Tags Help Center articles.

I hope this helps!

David

Hi,

Thanks for the help however it’s still not working. On the preview page I have the right prices with the “line total”, “tax” and “total with tax”. I have put “total with tax” in the column and the price without VAT still comes out.

Userlevel 6
Badge +5

Hey @Allegrapc,

Since it sounds like you do have a variable being synced from your ecommerce platform of “total with tax”, I would suggest ensuring you are formatting this syntax correctly when updating your email template. I would recommend taking a look at the following Help Center articles for more directions on how to do so:

David

Reply