Solved

Browse Abandonment not pulling in product viewed data for every visit.

  • 3 August 2021
  • 1 reply
  • 72 views

Badge

Hello all, I am having an issue with my browse abandonment flow right now.

I have noticed that some of my potential customers are viewing products, or Klaviyo/Shopify is thinking they are viewing products, and it sending out a browse abandonment email.

Problem is that this email isn’t pulling in any product data and I’m not really sure why.

It’s working about 70% of the time at the moment, but 30% are getting the email without any of the product info for the product they’ve viewed.

Attached image below!

No data in email preview
Email preview showing no data pulling in

 

icon

Best answer by david.to 3 August 2021, 23:19

View original

1 reply

Userlevel 6
Badge +4

Hello @RoldhamM4,

Thanks for sharing your question with the Klaviyo Community!

From my experience, the Viewed Product metric may be pulling in blank images due to either the product image being referenced is broken, the product is no longer published, or if you the Viewed Product code snippet was installed incorrectly. I suspect this may be the latter as we can see from the screenshots provided that the metadata being shared is pointing to your homepage of https://www.zipscanners.comIn the event that the Viewed Product code snippet is installed incorrectly causing the code to be recognized on your homepage, a collection page or any pages which may either be devoid of products or have several products; this would return a blank image when triggered. This is because the Viewed Product snippet is meant to only recognize and return the product information of a singular product each time it is triggered.

To resolve this, i would suggest reviewing how you have installed the Viewed Product snippet and ensure that you are following the instructions found in the Web Tracking Snippets subsection of the How to Integrate with Shopify Help Center Article. Essentially, you’ll want to make sure the Viewed Product snippet is installed at the bottom of your product.liquid file. When installed correctly, you should also only be seeing the code present only on your product pages and should not be present on any other webpages of your site. 

I hope this helps!

David

Reply