Solved

Cannot choose date property to trigger flow

  • 6 July 2022
  • 3 replies
  • 37 views

Badge +1
  • New Participant
  • 8 replies

Hi I’ve been trying to set up a flow with the trigger being a profile’s date property. The issue is that I cannot find the property I want to use in the dropdown list here:

 

I read a few posts and have checked and made sure the value was properly formatted. Some of the profiles don’t have this property but I thought they would just be excluded from the flow.


I was able to create the flow using the property I want as the trigger before, but I deleted it and created a segment-triggered flow instead. Now I have to come back to configure date property-triggered flow since segment-triggered flow doesn’t send email more than one time to one customer if they re-enter the segment. I also cannot use metric-triggered flow as I want to sent the emails 1 week before the actual date.

 

Can anyone help me with this? I’m so confused and lost :/

icon

Best answer by Dov 6 July 2022, 20:11

View original

3 replies

Userlevel 7
Badge +55

Hi @tieu,

Thanks for sharing this question with us.

I recommend following the steps here starting with my reply (the 6th post in the thread). This will walk you through “cleaning” out the profile’s date property entirely and then re-importing that value to ensure consistency. The reason why a date doesn’t appear in the dropdown menu is if there is an invalid date format on a profile (even if it’s just a single profile, unfortunately).

You are correct in that profiles that do not have the property at all will simply be excluded from the flow.

Thanks for being a community member.

 

Badge +1

Thanks! I will follow and try again~

Badge +1

hi @Dov 

i tried following your instruction you linked and even tried deleting the property i want everywhere and keep it in only one profile with the correctly formatted date (i checked with the doc and even tried with all of the formatted date in their example) and it still doesn’t appear in the dropdown

what confuses me is that i had no trouble setting it up last time, the date format wasn’t changed on my end or anything either…

thanks for your help tho! i also contacted support and hopefully they reply soon 🤞

Reply