Solved

First name not showing in automation eamil

  • 20 April 2021
  • 6 replies
  • 57 views

Badge

Hi,

 

I think I put the first name code in the automation flow, and it worked before. now I don't see first name being addressed in the opening email. Does anyone see the same?

 

 

icon

Best answer by MikeH 20 April 2021, 04:28

Hi there,

If there’s no name in the contact’s profile, then the parameter will leave it blank. Here’s an example of how to catch that, and insert something in the place of the first name if it’s missing:

Hey {{ first_name|default:'' }} 

Looks like this is what you’ve used in your email.  You see the “ at the end before the }} ? You can insert a default catch-all replacement there.  Like below:

 

Hey {{ first_name|default:'there' }}, I noticed you noticing me.

So, if my contact hasn’t supplied me with their first name, then this will see that and say:

“Hey there, I noticed you noticing me.

 

Let us know if that helps :)

View original

6 replies

Userlevel 4
Badge +3

Hi @popeia,

My pleasure! That is an odd case, it should be the case that it would display the name if properly integrated and it is pulling from the list. I can create a support ticket about this case so that we can have a product expert have a closer look into your account and see where the issue is occurring!

 

Thanks for your patience :)

Alex

Hi Alex, thanks a lot for your answer. 

We sent the Preview Mail as an email and put in my private mail address which is also on the list including my first name. Then only the default value appears: “there”. 

But when I select the option to show directly on Klaviyo and I insert my mailaddress, then the Preview shows it correctly with my first name. 

 

Is it correct then? What would you say?

 

 

Userlevel 4
Badge +3

Hi @popeia ,

 

Hope to have your question answered. By chance, are you sending preview emails out to customers on your list or just looking at the preview of the email template itself when you see that no name is pulled in; you can preview as a specific profile (contact), by inserting a specific email address when previewing. Klaviyo will pull the data assuming it is there, if there is no data to pull then naturally it will not populate.

To double check with the above replies as well, this process can be done in the Text box by using the Dynamic Tag. I recommend watching this demo video here which talks about great things you can do on your campaign to personalize it. Additional info can be found in our article on how to Insert Template Variables into Text Blocks.

Lastly, if you find that you are following all these steps and an error still occurs with populating the name, I would advise reaching out to our Support Team so they can take a personalized deep dive into your account.

 

Thank you and have a great day!

Alex

 

Hi there, 

 

maybe someone could help us here… 

We have the problem that when we insert {{ first_name|default:'there' }} the first name never appears on the preview Email. It always shows “there”. 

We put ourselves on the list in order to check it. 

Do you have any idea?

 

Thanks a lot! 

 

 

Badge

Thank you Mike!

Userlevel 2
Badge

Hi there,

If there’s no name in the contact’s profile, then the parameter will leave it blank. Here’s an example of how to catch that, and insert something in the place of the first name if it’s missing:

Hey {{ first_name|default:'' }} 

Looks like this is what you’ve used in your email.  You see the “ at the end before the }} ? You can insert a default catch-all replacement there.  Like below:

 

Hey {{ first_name|default:'there' }}, I noticed you noticing me.

So, if my contact hasn’t supplied me with their first name, then this will see that and say:

“Hey there, I noticed you noticing me.

 

Let us know if that helps :)

Reply