Solved

Issue with klaviyo plugin update

  • 10 February 2022
  • 3 replies
  • 130 views

Badge +1
  • New Member
  • 8 replies

I have been using klaviyo for years with no issues on Woocomerce. Yesterday i updated klaviyo to the latest version.

 

  1. Issue with no klaviyo setting page in woocomerce. The klaviyo is connected on woocomerce, but i can't look or edit any settings? How do i edit the consent box? It is gone, even though klaviyo and woocommerce is connected.
  2. I used to restrict source “accepted at checkout” in our welcome email flow. This does not work anymore. How can I restrict people from the checkout flow from receiving welcome emails? After the update, the source is API, which is common with many integrations and we are therefore not able to restrict the API source.
icon

Best answer by brandon.park 22 February 2022, 18:21

View original

3 replies

Userlevel 7
Badge +55

Hi @HPB,

Thank you for sharing this question with us.

Can you confirm whether you're seeing a settings option like this under the Plugins tab from your WooCommerce Admin? If not, you may want to check in with Woocommerce on this since this is a setting within their platform. 

 

 

On your second question, there should be a setting in Woocommerce to remove the email marketing consent checkbox from the checkout page altogether, (you would uncheck the box next to Add email marketing consent checkbox to your checkout page in the Woo settings-- the opposite of what’s described in the “Subscriptions” section of our documentation here). Alternatively, you could add a flow filter to your welcome flow: What somebody has done > Started Checkout zero times over all time. That, by definition will skip anyone who has ever started a checkout from entering your welcome flow. 

I hope that’s helpful!

Badge +1

Setting is there, its the fault of the Klaviyo update. It currently says that “Your Klaviyo plugin for WooCommerce is out of date” Even though, it's the latest version.

 

Badge +1

Hi @HPB,

It looks like the integration may not have synced with the updated plugin. Could you please try the following steps?:

1. First, remove the Klaviyo plugin from WooCommerce. 
2. Next, in Klaviyo, navigate to Integrations > WooCommerce and also remove your WooCommerce integration (not disable). 
3. Once both the plugin & the integration have been removed, go through this section in the WooCommerce integration guide to reinstall the plugin and connect with your Klaviyo account. Please check to make sure you’re on the right Klaviyo account if you own multiple accounts. 

Please note that reinstalling the plugin is going to require you to reconfigure your plugin’s settings, so if you are able to view its settings page beforehand, we would recommend taking a screenshot of that page to make the reinstallation process a little bit easier.

Please let us know if you’re still having trouble after taking these steps.

Reply