Solved

Klaviyo email requires "display image" in inbox

  • 20 April 2021
  • 6 replies
  • 408 views

Badge +1

Hi,

My automation email when sending to myself, It won’t show the image unless I press the button “display image”. Is there a way to automatically show the image?

 

 

 

 

 

the email I got from others seems like is from a image link or something. This below email I don't need to click “display image below” in order to show the image.

 

Does anyone know why?

 

icon

Best answer by Dov 21 April 2021, 15:01

View original

6 replies

Userlevel 7
Badge +56

Hi @delonghuang,

Thank you so much for sharing your question and exploring the Klaviyo Community for some solutions.

First, it sounds like this issue is only occurring when sending to yourself, correct? If so, I recommend clicking “Always display images from contact@minidrago.com” (rather than display image below) and see if this resolves the issue.

If you are noticing that this issue is occurring for other emails, it is likely due to your current Gmail settings. In this case, I recommend navigating to your Gmail settings and clicking always show images enabled for Gmail.

Lastly, if this email was in the Junk or Spam folder, it is expected that images will not display. In this case, you can simply drag and drop the email from your junk or spam folder into your primary inbox.

Thanks and have a great day.

Hello,

 

I have the same issue, but I suspect this what our subscribers are seeing on their end.

 

Ideally would be great if there’s a solution where it isn’t about going into settings of my own gmail, as I cannot expect all our subscribers to take those steps, let alone know how to.

 

Please let me know if there’s something we can do to fix! Or if I’m missing some key info. Trust you guys are the experts!

 

Thank you so much,

Charlie

Hi!

We have the same issue on our end. I have emailed Klaviyo for help but haven’t heard back. Any help on this issue would be appreciated.

 

Thanks!

This sounds like standard procedure for emails with pictures from anyone. I always have to click download or show pictures in emails. I think that is email client/account specific and not Klaviyo specific. 

I am having the same issue and notice that other people’s emails to me including another Klayviyo user display automatically, but for me I have to authorize Gmail to display them.

 

Very interested to learn if there is something to fix this.  Expecting people to edit their GMAIL settings just for my emails is unrealistic.

I would also be very pleased if this could be straightened out. Is it a certain image file format that triggers gmail to hide images by default or is there another cause?

Thanks,

Reply