Solved

SMS Campaign Recipient Count 0

  • 7 November 2021
  • 1 reply
  • 231 views

Badge

Hello,

I’m trying to send an SMS campaign and when I go to send it, I get this message. Even though I have three people on this list.

 

icon

Best answer by Dov 8 November 2021, 15:53

View original

1 reply

Userlevel 7
Badge +53

Hello @406 Balanced Living,

Thank you for sharing this question with the Klaviyo community.

First, can you confirm that these users’s have SMS consent logged on their profiles?

Since this is only for a handful of profiles, the easiest way to verify consent would be to navigate to the profile itself and look for the green checkmark.

Alternatively, you can create a segment of users who are in your SMS Subscribers list AND have Consented to Receive SMS consent. If this segment yields 0 recipients then you know none of these contacts have SMS consent logged.

 

If you find that these users have not consented to SMS, I recommend reviewing our article on collecting SMS consent to ensure this is being collected on the profile as it should.

More likely, however, the issue for 0 expected recipients is due to Smart Sending. When an email or SMS message has Smart Sending enabled, Klaviyo will automatically check to see if that recipient has received a message from you within your account's Smart Sending period before it sends. If this person has received another message from you within the Smart Sending Window, they will be skipped from receiving the current message (if all recipients are going to be skipped you’ll see an expected recipient count of 0).

To test if this was the cause of the problem, disable Smart Sending for this campaign by navigating to the checkbox related to enabling/disabling Smart Sending in the first step when you create a campaign. That should re-evaluate your expected recipient count when you advance to the sending stage.

smart_sending.png

Reply