Solved

Unable to get block to show up in confirmation email

  • 17 September 2021
  • 3 replies
  • 22 views

Badge

I’m in the process of re-doing a post purchase flow and for some reason, just in the order confirmation email, the block that contains the product details (image of products order, quantity, price, discount, subtotal, tax, shipping, and total) will not show up.

 

Has anyone else experienced this? Is there a reason an entire block wouldn’t be visible?

icon

Best answer by Bobi N. 17 September 2021, 09:45

View original

3 replies

Userlevel 5
Badge +3

@Katie C. 

This is hard to answer what may be the problem since dynamic product block is definitely available for placed order metric but than.. I’m not sure if you are using placed order metric or something else to trigger the flow

Another thing that I noticed people make mistakes is they use blocks from Abandoned Cart flow in another flows started with different metric which is not Started Checkout and then they are confused why the block doesn’t work for them. 

Klaviyo codes are different for different metrics so maybe you just need to make sure that this flow is started by Placed Order metric and it is using the dynamic codes for this specific Metric. 

Sorry I couldn’t be more specific but without looking directly into those emails all I can do is give suggestions on what I think may be the problem, hopefully it will help though.

Userlevel 4
Badge +4

Hey @Katie C. 

To add on to what @Bobi N. shared with you, which is 100% correct, order confirmation emails in your post-purchase flow are considered transactional emails and depending on your integration will require specific dynamic tags to pull the appropriate event data . If you are using Shopify you can use Klaviyo’s pre-built Shopify Notification Templates and export them into Shopify to use. The dynamic tags will not work in the preview until you have imported the template into Shopify. Check out these other Community Post about using transactional emails in different integrations

Thank you so much for being part of the Klaviyo Community!

Badge

Thanks all!! Issue was resolved, it wasn’t the correct data source. :face_palm_tone1:

Reply