Solved

Why all my emails from my flow being skipped?

  • 13 December 2021
  • 3 replies
  • 419 views

Badge

Hello Everyone,

I set up all my flows and emails. I noticed that ALL my emails are being skipped. Like every single one.

Abandoned cart, welcome series… All them. My welcome series send the first email, but after that all the other emails are being skipped. Why is this happening?

Thank you,

icon

Best answer by Bobi N. 14 December 2021, 08:31

View original

3 replies

Userlevel 5
Badge +27

@friendsupstudio 

You need to check your flow filters, email filters or smart sending option.

However if you go on the email that is being skipped, click on it in the flow, click on View all Analytics on the left side menu, than click on Recipient Activity in the top menu and go to skipped. When you click on skipped you will see all the different reasons why people are being skipped from your flow.

Userlevel 6
Badge +47

Hi @friendsupstudio

 

Welcome to the Community, we are so glad you’re here! 

 

 

As mentioned, there could be many reasons why your flow emails are being skipped. @Bobi N. hit the nail on the head with possible reasons this could be happening and how to further investigate what might be the culprit here. Thanks Bobi! Along with his suggestions, you can go to a profile, hit the top right hand button that says ‘Messages’ and navigate to the ‘Skipped’ section. This will also give you another reason to see why an email wasn’t delivered to them and what you can do to rectify the issue. 

 

I would first investigate whether Smart Sending is the culprit here. I would be wary to not turn off Smart Sending for your account solely for this reason however, as it provides a good customer experience so your customers aren’t bombarded with too many emails from your brand and unsubscribe altogether. 

 

Additionally, every potential issue our fellow user raised, Flow Triggers and FiltersAdding an Additional Filter to a Single Flow EmailSmart Sending in Klaviyo  s documented in our awesome Help Center to give you further insight into our product and functionality in your account. I’d also recommend taking a look at some of our Academy Courses to learn more about the Klaviyo product and level up your skills! I would recommend taking a look at the Getting Started with Klaviyo and our Product Certification Course courses to help you build a strong product knowledge foundation and get on your feet so to speak!

 

Thanks for being a part of our Community!

-Taylor 

Badge

Hi Guys!

Thank you very much for helping me here.  Yes, I started digging all over my flows and I noticed this “smart sending” filter was on. So I turned off and started to test again. It seems to be working.

Thank you again you both. :)

Reply