Solved

Why Do I see a ‘bad request’ outlook url when Clicking a Button in a Flow Message?

  • 11 April 2022
  • 1 reply
  • 129 views

Badge

Hi,

 

I tried linking my outlook calendar with Klaviyo behind a button, so people can schedule a call/meeting. The problem that I have is the following → when I test the flow and click on that specific button, i get redirected to a ‘bad request’ outlook url.

 

The link works, but not when it’s put in Klaviyo..

 

Does someone know, how I can fix this?

 

Thanks in advance!

icon

Best answer by Taylor Tarpley 12 April 2022, 16:32

View original

1 reply

Userlevel 6
Badge +51

Hi @Username

 

Welcome to the Community! Happy to help here!

 

In my experience, I’ve seen this happen if we're adding UTMs UTMs and Email to Website Tracking (The _ kx Parameter ) onto your URL which is causing this to break. In order to fix this you could persue one of two options:

  •  work with your site developer to allow for / accept URL Queries/Parameters to be accepted on this page. This would allow that URL to properly load the page with any UTMs or Query Parameters
  • to turn off UTMs and Email to Website Tracking for this send. However, the issue with turning off Email to Website Tracking is that while turned off, your email conversions will not calculate properly as we're 'removing the attribution' from the email links, which removes the ke_ paramter. 

 

 I’d suggest to follow the first option, if possible, to work with your Site Dev to allow for UTMs/Query Parameters to be allowed on that page and not cause the URL to break once added. If that's not possible, the only other option to get that URL to properly work would be to turn off UTMs and Email to Website Tracking, which then once sent will have that URL work properly as we're not adding any additional elements to the end of the URL.

 

Hope this helps! Thank you for posting in the Community! 

-Taylor 

Reply