Solved

Why is my Woocomerce Rebuild Cart Button Not Working?

  • 22 March 2021
  • 7 replies
  • 191 views

Badge

when i click “:return to your cart” they sending me mywbsite.com/cart and message oopss there no product

 
icon

Best answer by Dov 13 April 2021, 19:05

View original

7 replies

Userlevel 5
Badge +4

Hi @instabillo,

What ecommerce platform are you using? Is this inside of an Abandoned Cart flow? Can you provide screenshots?

Best,

Caroline

Badge

I'm  Using wooCommerce!

Yes, This is inside of an Abandoned Cart flow.

 

 When i Click Finish your order here..they send me www.naomi.today/cart

 

Same Problem facing customers abandoned email..

Userlevel 5
Badge +4

Hey @instabillo! Can you try using this as the link for that button? {{ organization.url }}cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

 

That will allow the cart to be rebuilt!

 

 

Badge

It's not working either

Userlevel 6
Badge +5

Hi @instabillo,

Thank you for your follow-up reply. And thank you @elisegaines and @caroline for your suggestions and input.

@instabillo, you may need to add a forward slash to your URL parameters between {{ organization.url }} and cart to resolve any errors with the destination URL. To add the forward slash, navigate to Table Block > Rows > Column 2 and double click the hyperlinked product title tag. Add the forward slash to the URL in the window and click OK.

forwardslash.png

 

If you are still having trouble after this, can you send me a screenshot of the destination URL and the tag you are using in the table block?

I have tried everything and still does not work :(

Userlevel 4
Badge +5

Hi @Andreab95

 

Thanks for sharing your question with us! 

 

I’m sorry to hear you’ve been experiencing issues with rebuilding your abandon cart! Can you confirm that you using the Woocomerce integration as well and have inserted the following code in the Button Block’s Link URL?

 

{{ organization.url }}/cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

 

If you have copied and posted this code in the URL box and are still having trouble, the issue could be your website is in a different language or your website uses another word besides ‘cart’ to describe your grouped products at checkout. If your website is in a different language, you will need to translate the word ‘cart’ into your website language and replace the English word for cart in your code.  I have seen other customers format their URL’s perfectly, however, needed to translate ‘cart’ in order for their link to properly function. I have also seen other users’ website’s use the word ‘basket’ instead of cart. I would test your website to ensure you’re using the proper word for you abandoned ‘cart’. 

 

I’d recommend checking out this Community Post on the same issue to gain further insight into this situation! 

 

Thanks for being a pat of the Community! 

 

-Taylor

Reply