Question

Understanding the ke parameter and Server-Side Events using the Track API


Badge

Hi would be great if you can help me with these two issues:

1) We are trying to visit website using ke_ parameter for Klaviyo integration and can see that we receive events. But in some cases we need to receive events without ke_ parameters (example in Incognito mode), but we went into Incognito mode and used tests email to place an order. The event shows correctly in Klaviyo, but no other events show up (like browsing).

2)  Additionally server side events are added to a different email address http://prntscr.com/1528b68 . So in the case when user was on checkout page - we didn’t receive an email from checkout, but it was replaced by the email that we use for Klaviyo accountThanks!


2 replies

Userlevel 3
Badge +2

@igorp Have you included the script which will request our klaviyo.js file? This is needed for onsite tracking. Here’s a page that helps with custom integrations in case you haven’t seen it: https://help.klaviyo.com/hc/en-us/articles/115005082927-Guide-to-Integrating-a-Standard-Ecommerce-Platform#on-site-behaviors--javascript-track-api-1

Userlevel 5
Badge +4

 Hello @igorp,

Thank you for sharing your questions with our Klaviyo Community! And thank you @jallain for your reply.

  1. May I ask why you need to receive events without the ke parameter? To clarify only the email to web tracking functionality relies on the ke parameter. This is one of the main ways Klaviyo is able to identify new site visitors and cookie them. Any other events (like placing orders) will function normally without the presence of the ke parameter.  Also, we cannot control when the ke paramter is applied based on the browser type or browser mode i.e. Incognito. It operates via a checkbox -- either on or off. We have more information on this here as well. If you wish, you can disable the _ke parameter on your URLs by going into your email setting and unchecking the following:

 

  1. You must include the $email field under the “customer_properties” section in the Track request. It looks like you have included it under “properties” which is why it’s being reflected as a custom property rather than being associated with the email address itself. I recommend reviewing our documentation on tracking events server side for an example: https://help.klaviyo.com/hc/en-us/articles/115000751052-Track-and-Identify-API-Reference#tracking-events--server-side-10

Thanks and have a great day.

Reply