Question

Bounce Rate Issue in Klaviyo

  • 22 September 2022
  • 3 replies
  • 10 views

Badge +5

Guyz I am getting a huge BOUNCE RATE on automated flows emails.

 

My Client recently purchase the domain from name cheap & started using klaviyo 20 days ago. But In these 20 days time spam, we face bounce rate in every flow

 

Specially in Abandoned Checkout & Customer Thank-You Flow

 

What could be the reason ? after 20 days I sent my first campaign. but I didnt face any bounce rate on campaign, but getting bounce on automated flows?

 

What’s The Solution

 

Abandoned Checkout                    | 8%

First Time Customer Thank-You    | 7%

Browse Abandoned                       | 3%

Abandoned Cart                            | 3% 

Customer Win-Back                      | 3%

Welcome Series                            | 2%

 

NOTE : These are the bounce rates I got in these 20 days.


3 replies

Userlevel 7
Badge +55

Hi @Anas Ali Khan,

Thanks for sharing this with us.

I recommend having a look through our documentation here. It will help you identify if the bounces are hard or soft, and explain why emails bounce.

In addition to this, I would check the domain being used for these flow emails, if you’re using a send address such as gmail or yahoo, you may see high bounce rates because the emails are failing DMARC. You'll need to update all flow emails to the "default sender email address" that includes your domain name. For example, you’ll want your sender email address to look like yourname@yourbusiness.com.

If this is indeed the case, I recommend updating this address to your business domain in the account settings too. This is because whatever is in the account settings will serve as the default address when you create future flow emails.

I hope that’s helpful.

 

Badge +5

Hey Dov, thanks for giving me the valuable answer 💙

 

But My client isn't using any @gmail or @hotmail.

 

My client is using a professional domain like support@brandname.com 

 

So maybe my client is using "Support", that's the reason we are facing bounce ?

 

Should I change the Support from Hello or Info or something like that ? 

 

I was using emojis in every flow, maybe that could be the reason.

 

Although Today I removed all the emojis which I was using in the subject line. 

 

 

Userlevel 6
Badge +25

@Anas Ali Khan in addition to what @Dov said also check if you have dmarc configured on your domain and that it's configuration is not mistakingly set to quarantine all. I think it's the p= setting that controls this.

 

Also make sure you run double opt-in and use good sending guidelines.
Check if you're not getting spammed with a lot of “fake”email addresses.

 

Those are a couple of things I could think of.

 

Omar Lovert // Polaris Growth // Klaviyo Master Platinum Partner

Reply