Solved

Can't get Web tracking script to install with BigCommerce. Says Script not installed correctly.

  • 6 December 2022
  • 3 replies
  • 30 views

Badge

I have reached out to support several times, and I keep getting very bad responses.

  1. We’ve searched your site and didn’t find the code. Well you searched  my live site, not the site i’m migrating to which isn’t live yet. DUH
  2. I have already been advised to REMOVE the integration, which did not work. 
  3. I instead removed the entire app from the store TWICE now. And reinstalled the script. Still no match.
  4. The error message I am getting when trying to verify is this: 
    Script was not installed correctly 
  5.  I have verified that the script is accurate. 
  6. I read the article for a Shopify store where there could be a conflict with other scripts. I do not have any other Klaviyo scripts installed. Only the auto script named Klaviyo JS Injection that is installed when integrating. Unless it conflicts with a separate script from another app? 

     

icon

Best answer by Brian Turcotte 6 December 2022, 17:11

View original

3 replies

Userlevel 5
Badge +26

Hi @cathywise and welcome to the Community!

 

I’m sorry to hear you’re having trouble with your integration! This issue could be caused by several things. May I ask the status of the SSL certificate for the new site? If you don’t know, you can check by entering the website address here - Klaviyo requires a grade A to integrate, so if it’s less than that you may need to update your SSL certificate to move forward. 

 

Also, if you haven’t already, I would suggest trying to manually check if the correct code is installed on your site through your browser console. While the snippet checker tool is useful, it’s possible that the snippets could be installed successfully and the checker missed it due to third-party interference. The best way to know for certain is to check via your console, and then test yourself by cookie-ing your own browser and clicking around your site to see if the events fire in Klaviyo.

 

Here are some more Community posts dealing with similar topics:

 

Thanks for using the Community!

- Brian

Badge

Thank you!

I am not live yet, so not sure if the SSL relates to this or not? I will upgrade the SSL before launch. Unless you think I would need to do that now while integrating?

The script is indeed installed correctly after manual testing. But the error message continues to display - which is not very useful for beginners setting up.  Lesson learned though - this new BC/Klaviyo process will not go smoothly as planned.

 

Again, thanks!

Userlevel 5
Badge +26

Hi @cathywise,

 

Glad to hear the script’s installed - I would recommend upgrading the SSL certificate as soon as possible, because in other similar cases it has been the source of integration issues. If your testing was successful however, it’s probably not imperative at this time. 

 

I’ll also definitely forward the integration-checker feedback to our product team. If it’s still showing the error message, it’s usually because of some third-party code/plug-in interference, but it’s always good for us to inspect occurrences like this.

 

Thanks again for using the Community!

- Brian

Reply