Solved

Getting url not recognize when add store url

  • 3 February 2021
  • 5 replies
  • 257 views

Badge

Hi, 

I am trying to login to Klaviyo to my Magento 2 store but I am getting the following error:

 

Unable to connect to your store, check your provided URL.

 

I confirmed that the url is correct.  Any help would be appreciated.

 

Thanks

icon

Best answer by retention 3 February 2021, 06:21

View original

5 replies

Userlevel 7
Badge +5

@cmartin - There might be people who are more familiar with Magento in the community, but let me point out some (maybe obvious?) things to try:

  • Did you Install the Klaviyo Extension in Magento first?
  • Have you provided the correct Public API Key (often confused with the Private API Key)
  • Did you create a Magento API credential? (make sure you have the username/password for Klaviyo to use).  Try logging into your Magento directly with this to see if you have the correct username/password.
  • Does your Magento instance have some kind of security infrastructure that allows Logins from a specific IP address (or users only? do you use a VPN?)  Klaviyo’s server will need to be able to “login” into Magento - so make sure you provision the appropriate access.

I’m sure you’ve seen this guide,but just in case, review the steps here:

Hope this helps!

Badge

Hi,

I was able to resolve the issue by removing firewall I forgot was in place.  Can you please let me know what ip addresses I can use to whitelist Klaviyo as we do not want the site to be without a firewall for the sake of connecting to Klaviyo.

 

Thanks

Userlevel 5
Badge +4

Hi @cmartin,

Because Klaviyo uses dynamic IP addresses, we cannot provide a list of IP addresses to whitelist. However, you can whitelist our user-agent, which is Klaviyo/1.0.

Best,

Caroline

Hi, 

I’m having a similar issue although we are on Magento 2.4.2 EE Cloud with 2FA enabled. We are sending Newsletter signups and I can see in the Klaviyo analytics that the product views are being posted however I am not able to setup the Integration to Magento2 from the Klaviyo Integration tab. I get the following error : Unable to connect to your store, check your provided URL.

I can confirm that the user (klaviyo_api) and password can log into the Magento Admin. I don’t believe we have any restrictions (firewall, etc) as this is a Magento Cloud solution.

Ive seen a post that suggests 2FA maybe an issue with the extension. Any guidance on how to get the integration complete so we can start sending order / shipment confirmations and abandon cart emails.

Do we simply need to turn off 2FA in the admin for this to work?

Thanks

Jeff

Userlevel 1
Badge

@jsmathot I am going to send you a message from our support ticketing system.  Currently api access with TFA enabled will not work with Klaviyo.  We are trying to release a new solution using OAuth1 api access instead.

Reply