Solved

Magento 2.4.1 Integration Issue

  • 19 August 2021
  • 10 replies
  • 282 views

Badge

Following the instruction to install the extension for magento 2.4.1 I came across an error when activating the integration. Once click integrate Magento 2 on the popup window, I was told the error message below. I double checked the API details are correct, and also the firewall Sucuri is not blocking Klaviyo. Anyone has experienced the same issue? 

 

There was an error while integrating your Klaviyo account with Magento 2. Below are the details about your error

Klaviyo is unable to connect to Magento Server for OAuth Handshake.Url tried was: https://www.xxxxxx/oauth/token/requestPlease ensure that both /oauth/token/request and /oauth/token/accessare accessible
icon

Best answer by klaviyojad 20 August 2021, 11:30

View original

10 replies

Userlevel 1
Badge

@AndreAS that is correct unfortunately you cannot integrate with Klaviyo unless the site was a public url.  Also you will need to provide exceptions to authentication for calls coming from Klaviyo.  Klaviyo can only connect to Magento using auth tokens and cannot handle anadditional layer of credentials.

@AndreAS that is correct unfortunately you cannot integrate with Klaviyo unless the site was a public url.  Also you will need to provide exceptions to authentication for calls coming from Klaviyo.  Klaviyo can only connect to Magento using auth tokens and cannot handle anadditional layer of credentials.

 

Can anyone give the Ip´s used from Klaviyo in order to whitelist it and this way try to connect to staging environment?

Hi @klaviyojad I already ffound your other reply related to my question.

Please, any other with my question see @klaviyojad recommendation and post 

Thanks

Userlevel 1
Badge

@Ryancaremax I have to initially ask if the store url of your magento is publicly accessible to the web?

Moreover what do you get as a response if you plugged the Urls tried in the error message in your browser?

Does the response start with: ”oauth_problem=”?

If not then its an indication that the server rewrite rules are not set up correctly to route to the oauth api endpoint in magento2.

Badge

@klaviyojad thanks for the reply. Yes the website is public. When I type the URL in the browser it’s response is 

oauth_problem=%22oauth_consumer_key%22+is+required.+Enter+and+try+again%2C+%22oauth_signature%22+is+required.+Enter+and+try+again%2C+%22oauth_signature_method%22+is+required.+Enter+and+try+again%2C+%22oauth_nonce%22+is+required.+Enter+and+try+again%2C+%22oauth_timestamp%22+is+required.+Enter+and+try+again

 

 

 

Userlevel 1
Badge

@Ryancaremax thank you for the response.  Could you confirm that deleting the integration entry of Magento 2, recreating it from the Klaviyo Extension and activating produces the same error?

If so then we would need to work on this case via a support ticket.  A member of Klaviyo Success Engineers would need access to Magento Admin to investigate more closely.

Badge

@klaviyojad  Yes it has the same error after doing what you said. I already submitted a ticket two days ago and waiting for the first response. 

Userlevel 1
Badge

Apologies on the delay in response.  I have located the ticket submitted for the account id and responded to it.  You should have received an email if you were the original sender 

Userlevel 4
Badge +4

Hey @Ryancaremax 

Thank you so much for reaching out to the Klaviyo Community for integration support! @klaviyojad Thank you for jumping in to help solve this challenge! It’s collaboration like this that makes the Klaviyo Community, and Klaviyo as a whole, so much stronger. I’m grateful that as a team, we are able to help solve most challenges together.

Thank you @Ryancaremax and @klaviyojad for being a valued part of our community!

Hi all,

 

I’m getting the same error running an Magento 2.4.1 store version.

In my case,I’m trying to connect an stagging acccount to see how things first works, and to not run into problems in the live account.

I see that @klaviyojad had ask if the website url is public… In my case it is not, since it is a stagging account, and it is protected by a user and password to access.

Is this an problem, and can this be the origin to get the exactly same error has first reported?

Reply