Solved

Magento 2 Integration - Change URL for store

  • 15 March 2022
  • 2 replies
  • 59 views

Badge

I am currently using Magento 2.3.4. I want to integrate klaviyo extension in it.

My store url looks like: https://xx.xx.xx.xx/magento234

Path for that in my instance is: /var/www/html/magento234 

So I am using the path to be mentioned in the store url.

Currently my problem is: When I try to integrate with the extension in OAuth, it only takes the ip of my instance. i.e., “https://xx.xx.xx.xx/oauth/token/request” instead of “https://xx.xx.xx.xx/magento234/oauth/token/request” . So what can I do to solve this problem?

 

icon

Best answer by alex.hong 15 March 2022, 19:27

View original

2 replies

Userlevel 6
Badge +52

Hi there @JDhere,

Welcome to the Community!

Do you have any firewalls or security layers on your site? We typically see this error for the following reasons:

  • Firewall or security layer blocking our requests or making the endpoints not reachable
  • Bot Fight Mode on Cloudflare blocking Klaviyo bot. If you have Bot Fight Mode enabled, you will need to disable it for the integration to work
  • Your server re-routing our requests


It might be best to start out with the security layer. What do you have set up for firewalls (ie. Apache, Cloudflare, etc)?

 

EDIT: Resolved in support. Custom issue. 

Thanks.

Alex

Badge

Actually I am not using any firewalls. I am having the magento as a sub folder concept in the machine.

Scenario:

In my machine there are 3 magento instances so I am using a sub folder structure to access them.

DocRoot: /var/www/html/

So I access all the instance by,

  1. https://xx.xx.xx.xx/magento234
  2. https://xx.xx.xx.xx/magento234staging
  3. https://xx.xx.xx.xx/magento234testing

So in this order I access the instances. Now I try to integrate klaviyo, it only takes my IP, but I have not mapped any magento instances while accessing that IP. Only if the sub folder is added in the url my magento instance will be accessible. If you try to access the IP apache page will only come.

 

So what I need is “https://xx.xx.xx.xx/magento234/oauth/token/request” instead of “https://xx.xx.xx.xx/oauth/token/request” . So I need a method or process on doing that.

 

Currently klaviyo is going to this url: “https://xx.xx.xx.xx/oauth/token/request” , which won’t work in my case.

Reply