Solved

Magento 2 Private API Key field in general settings is disabled

  • 2 November 2021
  • 2 replies
  • 69 views

Badge

Magento version: 2.4.1

Klaviyo version: 3.0.9

 

Installing with Composer

On local machine with custom domain name (.local)

No TLS/SSL certificate

 

I can’t follow the instruction from https://help.klaviyo.com/hc/en-us/articles/115005254348-How-to-Integrate-with-Magento-2-x-CE-and-EE-#install-with-composer--2-4--2 since the “Private Klaviyo API Key” field is disabled for no reason.

 

After Composer installation, I’ve already run:

`bin/magento module:enable Klaviyo_Reclaim --clear-static-content`

`bin/magento setup:upgrade`

`bin/magento setup:static-content:deploy -f`

 

I’ve also tried uninstalling the extension and re-install it again using Composer. Nothing works. Please help.

 

icon

Best answer by klaviyojad 2 November 2021, 02:03

View original

2 replies

Userlevel 2
Badge +8

@shiwawan although I am surprised that the private api key field is blocked.  Maybe its due to having to enter public key first?

Regardless you will not get very far with the setup process as when you get to the setup oauth step it will not work because it requires a handshake process between the Klaviyo server and your localhost magento 2 server.  As you can imagine since your server is local its impossible for the Klaviyo server to connect to it.

Badge

@shiwawan although I am surprised that the private api key field is blocked.  Maybe its due to having to enter public key first?

Regardless you will not get very far with the setup process as when you get to the setup oauth step it will not work because it requires a handshake process between the Klaviyo server and your localhost magento 2 server.  As you can imagine since your server is local its impossible for the Klaviyo server to connect to it.

Thanks for the reply. I’ve already tried setting the public key first, but nothing changed. Regards to the “setup oauth” step you’ve mentioned, I’ll try to set it up again on my staging site then.

Thank you!

Reply