Solved

Recharge and Klaviyo integration - what am I missing

  • 17 August 2021
  • 7 replies
  • 84 views

Badge

Hi folks, scratching my head regarding integration with ReCharge.  Hopefully there is sufficient context in here that people can point out what step I may have missed or done incorrectly.

In support docs/instructions, it states that I need to integrate/connect with Klaviyo from Recharge first:

This is done and API key accepted.  Nothing shows up in Klaviyo however, and any backfill or sync doesn’t seem to do anything.

When I go to see if I can enable the integration from Klaviyo side I get this:

Now, this is a very new Klaviyo workspace and I am learning as I go so is it possible that there could be a background setting that needs enabling before this all works?

Admin tells me my “Shopify store is connected” in green, however any Shopify sync in integrations seems to be permanently pending (it has stayed like this throughout)

Is it the case that Recharge can’t work without the above singing along, or is it (as I suspect) that some background account setting needs to be changed.

Hopefully this makes sense!  Please ask any questions needed and I’ll try and reply as best as I can.

Thanks very much in advance, sorry if this is a dumb problem.

icon

Best answer by jallain 17 August 2021, 17:56

View original

7 replies

Userlevel 4
Badge +3

@Iain is seems that your Shopify integration may have been disabled. Can you go back to the integration in Klaviyo and re-enable it if that is the case? Once that is active, you should be able to try creating the integration through ReCharge again but it likely won’t work if your Shopify integration is disabled when you try to create it.

Badge

Hi Jallain,

 

Thanks for getting back to me.  It shows as enabled in Klaviyo, but when I try to disable and reenable I get the following:

 

Trying to push settings to Shopify, I get this on a shopify error page:

 

Oauth error invalid_request: Your account does not have permission to grant the requested access for this app. You may be able to resolve this issue by installing the app as the account owner

Userlevel 4
Badge +3

@Iain what does the integration look like on this page? https://www.klaviyo.com/integrations

 

Does it have a green bar next to it or does it say ‘sync in progress’ or anything like that? If you can click “Re-Import Historical Data” towards the bottom of the page it should kick off your historical sync. If that can run then the integration should be good to go and you can try re-creating the ReCharge one again.

Badge

Hey Jallain,

It’s always said Sync in progress (see screenshot earlier in thread)

As a side question, is it possible not to sync/import records from Shopify (core), but just from recharge?  I’d like to start using Klaviyo only with my subscription customers (i.e. Recharge)

 

Thanks

Userlevel 4
Badge +3

@Iain It could be that the sync from last time is stuck, if you can click “Re-Import Historical Data” that should get things moving again if the integration is healthy.

For your second question, you need an active Shopify integration to be able to use the ReCharge integration. You can configure your Shopify integration to not track users on your site by removing the onsite javascript. You can also uncheck the “Collect email subscribers” box if you don’t want to subscribe every customer that opts-in during checkout.

 

 

What would probably be best though is to continue collecting data from Shopify in case you ever decide you do want to use it. The ReCharge metrics should show up as their own metrics not tied to your Shopify metrics, so if you only want to use Klaviyo to contact your subscription customers, you should only build Flows based around those ReCharge metrics you want to use and just ignore the Shopify metrics in your account until you decide that you want to use them.

Badge

Sorry to be very dense here but where do I find: Re-Import Historical Data

^Can’t see it anywhere, if you can screengrab where it should be, that’d be great.  Thank you

Userlevel 4
Badge +3

@Iain It may not be showing to you if your historical sync never ran in the first place. Instead can you remove the integration and then add it again? Adding it should enable the historical sync to attempt to run again as well. You’ll have to fully remove it instead of just disabling it. 

Reply