Solved

"Unable to access the orders API, please check connection settings and try again." with WooCommerce

  • 13 April 2022
  • 7 replies
  • 94 views

Badge +2

I was updating the Klaviyo plugin for my account but I got the "Unable to access the orders API, please check connection settings and try again." error while reinstalling from scratch. 

Here are the specific steps I took and the WP and WC versions, as well as the Firewall status.

1. Deleted the Klavyio Plugin

2. Deleted the REST API Key

3. Followed the guide here: https://help.klaviyo.com/hc/en-us/articles/115005255808-How-to-Integrate-with-WooCommerce

Result: Got the "Unable to access the orders API, please check connection settings and try again." error

4. Revoked the REST API keys created from the integration

5. Created a REST API key

6. Did the troubleshooting section here: https://help.klaviyo.com/hc/en-us/articles/115005255808?wtime=%7Bseek_to_second_number%7D

7. Insomnia returned an order number from the Get Order Request

8. We tested the woocommerce order API through Insomnia and it is returning valid response. but integration page is returning,

 

Unable to access the orders API, please check connection settings and try again.

 

Although API is returning valid orders.

 

Versions

WooCommerce: 5.6.0

Wordpress: 5.8.3
Firewall for Upcloud server is disabled

Really need help on this.

icon

Best answer by Dov 25 April 2022, 15:09

View original

7 replies

Userlevel 7
Badge +54

Hi @razzorax,

Thanks for sharing this information with us.

I noticed you found and posted in the thread below:

 

Here are a few other things to try:

  1. Try whitelisting our user agent "Klaviyo/1.0"
  2. Ensure requests are allowed to Klaviyo's custom endpoints at /wp-json/klaviyo/v1/*
  3. Confirm with us what hosting provider you are using

Also, I’d recommend placing an “@” symbol before Diyafury’s name in that thread to notify him that he’s been mentioned directly. If you do not hear back from him shortly and you after you confirm you’ve done the above steps, just let us know and we can take next steps from there.

Badge +2

Hi @razzorax,

Thanks for sharing this information with us.

I noticed you found and posted in the thread below:

 

Here are a few other things to try:

  1. Try whitelisting our user agent "Klaviyo/1.0"
  2. Ensure requests are allowed to Klaviyo's custom endpoints at /wp-json/klaviyo/v1/*
  3. Confirm with us what hosting provider you are using

Also, I’d recommend placing an “@” symbol before Diyafury’s name in that thread to notify him that he’s been mentioned directly. If you do not hear back from him shortly and you after you confirm you’ve done the above steps, just let us know and we can take next steps from there.

HI @Dov 

Thanks for the response. Regarding the steps done:
1. As per Upcloud, they don’t whitelist/blacklist applications/softwares. (Firewall is disabled too)
2. Did the request for the custom endpoints for 2 versions:
- /wp-json/klaviyo/v1/* (With the asterisk)(I get a 404 not found error)
- /wp-json/klaviyo/v1/ (Without the asterisk)
Kindly see screenshots for both results
3. Hosting provider is Upcloud
Also added the “@” to the thread mentioned. 

This is the error for the GET request with the “/wp-json/klaviyo/v1/*”
{
    "code": "rest_no_route",
    "message": "No route was found matching the URL and request method.",
    "data": {
        "status": 404
    }
}
 

 

Userlevel 7
Badge +54

Hi @razzorax,

Thanks for sharing this update with us.

I noticed you opened up a support ticket and are currently corresponding with a member of our team on this issue. At this point, I recommend continuing with that correspondence, and if need be, one of our engineering team members will have a closer look at your specific use-case.

Also, if you hear back from Diyafury and that helps resolve your issue, it would be helpful if you could share that here as well.

Thanks for being a member of our community.

 

Badge +2

Hi @razzorax,

Thanks for sharing this update with us.

I noticed you opened up a support ticket and are currently corresponding with a member of our team on this issue. At this point, I recommend continuing with that correspondence, and if need be, one of our engineering team members will have a closer look at your specific use-case.

Also, if you hear back from Diyafury and that helps resolve your issue, it would be helpful if you could share that here as well.

Thanks for being a member of our community.

 

Hi @Dov,

Thanks for the response. Hoping to get a response from your team after a few days. Hope to hear a feedback soon since this greatly affects our email efforts. 
I’ll let you know if I get a response from Diyafury. 

Hope to hear from your team soon. 

Hi @all!

I’m having with the same problem in integrating their plugin. I’ve followed all the instructions and turns not working. I'm looking forward on this thread to get solution.

 

 

This is the error for the GET request with the “/wp-json/klaviyo/v1/*”
{
"code": "rest_no_route",
"message": "No route was found matching the URL and request method.",
"data": {
"status": 404
}
}

 

Userlevel 7
Badge +54

Hi @superfast,

Thanks for sharing this with us.

I’ve opened up a support ticket on your behalf. A member of our team will reach out to you shortly with next steps.

Thanks for being a member of our community.

Thank you so much @Dov !

Reply