Solved

Why is my WooCommerce/Klaviyo integration causing an error: "Klaviyo extension is uninstalled or unavailable"?

  • 20 December 2020
  • 10 replies
  • 417 views

Badge

Hi

I am trying to create the integration between Woo/Klaviyo.

 

I have set up the REST API and entered the Consumer key etc but am getting this message:

 

The Klaviyo extension is uninstalled or unavailable.

 

What is causing this?  Could anyone point me in the right direction please?

 

Many thanks

 

 

icon

Best answer by cassy.lee 9 March 2021, 16:40

Hi @EmptyChair, thanks so much for sharing how you were able to resolve this issue! 
@DarlingShop @KarimH - just to close the loop on this thread: plugins in WooCommerce that try to cache our javascript files can cause issues like this. It’s recommend that you disable caching if the plugin allows you to do that, or you can try to remove the plugin and test the Klaviyo integration again. 

View original

10 replies

Userlevel 6
Badge +4

@DarlingShop Hi there,

Make sure that in the settings of the Klaviyo plugin in Wordpress, you insert the Public API Key, and not a private API Key. You can find the Public API Key here:
 


That’s one of the common mistakes that can happen.

Here’s the Klaviyo documentation, where you can find a great step-by-step video that explains how to integrate WooCommerce with Klaviyo.


Hope this helps!

Badge

Thanks, I have followed these instructions to the letter and now have the problem and checked the public keys etc before raising the question - raised here as I was stumped.

 

Not sure where else to look for a solution.

Userlevel 5
Badge +3

Hi @DarlingShop, do you know what version of the extension Wordpress is running on? You should be able to find this under Plugins in your Wordpress admin panel. That could potentially help determine if your plug in is up to date or may need to be updated which might solve this. 

Hello there, I am having the exact same problem. 

I did follow the instructions exactly as outlined- used the public API key (not the private one). Still getting the same error:

The Klaviyo extension is uninstalled or unavailable.

Our versions are:

  • Klaviyo (WP extension)  Version 2.3.6
  • Wordpress 5.6
  • Woocommerce Version 4.9.0 

Appreciate any suggestions - thank you!

FYI → I disabled W3 Total Cache JS minify and it fixed the problem.
 

Userlevel 6
Badge +5

Hi @EmptyChair, thanks so much for sharing how you were able to resolve this issue! 
@DarlingShop @KarimH - just to close the loop on this thread: plugins in WooCommerce that try to cache our javascript files can cause issues like this. It’s recommend that you disable caching if the plugin allows you to do that, or you can try to remove the plugin and test the Klaviyo integration again. 

I tried everything on this including disabling caching and am still getting the same error.

@cassy.lee I am having the same problem but don’t know where to disable W3 Total Cache.  Can you help? 

Userlevel 5
Badge +4

Hi @Care,

Thank you for your reply.

You’ll be able to disable W3 Total Cache from the Plugins tab. There’s a complete guide on W3 Total Cache settings here.

Additionally, here is a Wordpress post on disabling minify.

I recommend just disabling minify initially and, if you’re still having trouble, then disable the W3 Total Cache plug-in.

Thanks and have a great weekend.

Thanks @dov.derin 

 

I don’t have the W3 Total Cache plugin installed I guess as it isn’t in my list.  Am I supposed to have it there?

 

Reply