Solved

WooCommerce Integration Unable to access API with credentials specified.

  • 28 November 2021
  • 5 replies
  • 139 views

Badge

I have tried many times and emailed the help center and they told me to download and set up the 2.4.2 plugin but I have not fixed my problem yet.

My problem is I can't do WooCommerce Integration, when I do everything according to your instructions then I am called "Unable to access API with credentials specified".
 I hope solution very quickly. you can understand that I am adding some screenshots.

 

icon

Best answer by Dov 29 November 2021, 17:24

View original

5 replies

Userlevel 7
Badge +45

Hello @Tahsin Hossain,

Thank you for sharing this with us.

I recommend reviewing the entirely of each thread linked below, there are several different potential causes and solutions for this issue:

Hope that is helpful!

Badge

I clicked on 3 options and checked with it as per his instructions,https://www.example.com/wp-json/wc/v3/products?consumer_key=my-consumer-key&consumer_secret=my-consumer-secret
You see, it shows my results.

please Help me fix it

 

Userlevel 7
Badge +45

Hi @Tahsin Hossain,

Thank you for this update.

Based on the issue you’re describing, it sounds like you’re facing a permissions-based issue. 

Can you confirm that the Klaviyo REST API user has Read/Write permissions set?


mceclip2.png

 

This step is also outlined in our help guide on integrating WooCommerce.

I am facing the same issue, did you have any luck in resolving this? Would appreciate any help!

Userlevel 7
Badge +45

Hi @loveshackgiftware,

In addition to my comment above, did you have a chance to review the threads linked in the best reply to this thread? There are a number of potential solutions outlined there as well.

Reply