Solved

SMS Consent Timestamp via csv

  • 5 December 2021
  • 5 replies
  • 199 views

Badge

I collected subscribers using Unbounce landing page software. The integration doesn’t allow sms consent to be passed through, so I am trying to upload a csv with the sms consent timestamp included.

The upload appears to be successful, but when I check the profiles, the sms timestamp field doesn’t end up being populated with the data I’ve uploaded. 

The Unbounce form we used includes consent acknowledgement that complies with the Spam Act in Australia, so everyone who enters the form is explicitly consenting to sms. 

Hoping someone can help!

icon

Best answer by David To 6 December 2021, 22:20

View original

5 replies

Userlevel 7
Badge +53

Hey @samgood1,

Glad to hear you’ve went through most of the basic troubleshooting steps. Because this sounds to be account specific, I would suggest the next course of action would be reaching out to our Klaviyo Support Team who can take a more in-depth look at this account and identify what the cause of this odd behavior could be. 

We would also love it if you would be able to share a solution too once the cause has been identified as this could help other Community members who run into a similar issue!

David

Badge

Hi David

 

Yes, I thought that may have been the problem initially. But I fixed that and still, the sms consent didn’t work. 

Userlevel 7
Badge +53

Hey @samgood1,

Since it sounds like you were able to successfully import SMS consent for a different Klaviyo account, you must be doing something right!

One other potential culprit that comes to mind since you mentioned you were Australia based is ensuring you have set up and activated your alphanumeric number within your account prior to importing these contacts. When SMS is first enabled in your account, you will be automatically issued a complimentary Toll free number. This phone number can be used to send SMS and MMS to US and Canadian subscribers but not UK and/or Australia numbers. 

Without activating a free alphanumeric sending number for UK or Australian numbers prior to collecting consent for Australian or UK subscribers, consent will not be stored on the customer profile. This includes importing UK/AU contacts via a .CSV. 

David

 

Badge

Hi! Thanks for your reply.

 

I can confirm sms is set up in the account.

 

I can confirm the csv file included sms timestamp (correctly formatted), country, phone number (correctly formatted), email, consent. We also ticked that we had explicit consent.

 

The only field that didn’t populate was the time stamp.

 

FYI we went through the same process with another Klaviyo account of ours, and it worked perfectly. We’re not sure what we’ve done differently with this one...

Userlevel 7
Badge +53

Hello @samgood1,

Interesting case you have here!

Can you confirm if you’ve enabled SMS within your account before importing these contacts to your Klaviyo account? From my experience, a common reason why SMS consent isn’t be collected within an account is that the SMS feature hasn’t been turned on in the account yet. You can learn how to get started and enable the SMS feature if you haven’t already from the Getting Started with Klaviyo SMS and MMS Help Center article.

I’ve also come across cases where users have trouble importing SMS consent to Klaviyo using a .CSV if certain data points are missing or if they’ve mapped the data points incorrectly. Keep in mind that in addition to importing an SMS consent timestamp, you’ll also need to include both the Phone Number and the Country of the user to successfully collect SMS consent via a .CSV import. 

Mapping the data points accurately is also a crucial step as it defines what the data points in the .CSV are for meant for. As mentioned in the Guide to Uploading a List of SMS Contacts Help Center article:

If you uncheck the SMS Consent Timestamp box during the mapping process, you will be able to upload your list of contacts successfully, but won't be able to text these contacts until the SMS Consent Timestamp field has been added.

What this means is that all those contacts within your .CSV will be added to the specific Klaviyo list you are importing to, but SMS consent would not be collected for these users. In order pass SMS consent for these profiles, you’ll need to re-import the .CSV while including this field. 

Lastly, I would suggest double checking to make sure that both your phone number fields and your SMS Consent Timestamp field are formatted correctly. You can find out the acceptable format of phone numbers and date fields from both the Accepted Phone Number Formats for SMS in Klaviyo and How to Format Date Variables in Templates Help Center articles.

Thanks for being a part of the Klaviyo Community!

David

Reply