Solved

Default Klaviyo Properties not showing up

  • 5 March 2021
  • 3 replies
  • 149 views

Badge

I’m working on a brand new Woocommerce site that is NOT live yet..the Klaviyo integration seems to be working fine (I see active on site and checkout started data), however, I don’t see any of the default Klaviyo property data when I’m trying to create flows. Is it because the site is not live and has no orders?

Also, my signup form is not being detected on the site - is this also because the site’s not live?

icon

Best answer by cassy.lee 10 March 2021, 04:26

View original

3 replies

Badge

bump : )

Userlevel 6
Badge +5

Hi @jeremyc
Apologies for the delay - is this still an issue you are experiencing? There was a similar post in the community a little while ago that I think might be applicable here as well: 
 

This is the answer I shared with Meeta, which I think is also happening to you when you’re looking for the properties: 


If you have created some custom properties for users to pass through a flow, the custom properties first has to exist on a customer profile before they'll appear in the segment drop-down option. So if zero profiles have gone through that step in the flow, the property won't show in the segment builder. If you want to test a customer property, I would recommend pushing a profile through the flow and manually add the property to a profile in the account (via CSV file upload or by manually adding on the profile page). You can learn more about custom properties and how to manually add them to a profile with this guide.

 

Regarding your question on why your signup form isn’t showing - you’re spot on that it’s because your page isn’t live! More details on that in this Community post: 

There’s also this handy Signup Form Troubleshoot guide that might offer additional insight too!

Hope this is helpful and points you in the right direction! 
-Cass. 

Badge

Awesome, thanks for the reply!

Reply