Solved

Double opt-in stopped working

  • 24 April 2021
  • 4 replies
  • 358 views

Badge +2

I just started setting up my account and testing the first signup form. Everything was fine and double opt-in emails started arriving into my inbox. Some time later this stopped working. 

I checked that my list still has double opt-in enabled, and that the emails are not ending up in the spam folder. They just stopped coming out. 

The only thing I can think of is that I edited the template for double opt-in but the only thing I changed was the text label.

 

Any clues on where to look for solutions?

icon

Best answer by Dov 26 April 2021, 17:43

View original

4 replies

Userlevel 2
Badge +6

Hi @JaSn 

 

Thanks for sharing with the community!

 

Are you signing up on the form with the same email? You will only receive a double opt-in email once per email per list. 

 

If not, it would definitely be helpful if you could provide any additional information about the steps you are taking to recreate this issue. This way, a member of our community may be able to chime in with more advice!

 

There was an FAQ that was added in the Community here that might provide a little more clarity on some of the reasons why Double Opt-In emails weren’t going to the right place:

It’s also possible that these profiles were created within your account, but were not added to any lists, so they wouldn’t be considered as consented yet.

 

 

Badge +2

Thanks for the reply. I use a different email with the + trick. Here's what I tried:

  1. address1+testA@gmail.com - not showing up in 'Profiles', no double-opt in email
  2. address1+testA@gmail.com again - showing up in 'Profiles' no double-opt in email
  3. Opened Incognito window, tried address1+testB@gmail.com - not showing up in 'Profiles', no double-opt in email
  4. address2+testA@gmail.com from another computer - showing up in 'Profiles' no double-opt in email
  5. Back to my computer with standardaddress@standarddomain.com - showing up in 'Profiles' no double-opt in email

I understand that there might be some delay in adding the email to the db but in all these tests I have never gotten the double-opt email.

In the very beginning it was working fine and I was getting them into my inbox. I checked 'all mail' and 'spam' folder in each case.

 

When looking at a specific profile, how can I tell if it was send the double opt-in email? How can I tell an address is already approved?

 

Thanks.

Userlevel 7
Badge +56

Hi @JaSn,

Thanks for sharing that additional context with the Klaviyo Community and thank you @marissanunez for your reply.

@JaSn it is possible to trigger an IP block if you sign-up through the same form multiple times from the same IP within a short amount of time. Our support team can whitelist that IP address to remove the blockage. Please note that whitelisting the IP will dispatch all double opt-in emails that have been “queued-up” during this time. An alternative is to use single opt-in. I’ve created a support ticket to loop them in to help and you will receive a follow-up note shortly.

Badge +2

 

@JaSn it is possible to trigger an IP block if you sign-up through the same form multiple times from the same IP within a short amount of time. Our support team can whitelist that IP address to remove the blockage. Please note that whitelisting the IP will dispatch all double opt-in emails that have been “queued-up” during this time. An alternative is to use single opt-in. I’ve created a support ticket to loop them in to help and you will receive a follow-up note shortly.

That was it! I tested from a different IP and it works as expected. I was surprised that the filter got triggered, because it happened after only three tests. Thanks for the help.

Reply