Solved

Embedded Sign Up forms not displaying in the Instagram webview browser

  • 4 August 2022
  • 2 replies
  • 15 views

Badge

Tackling an on-going issue where embedded forms do not render. While this is related to ad blocking, we have a specific repeatable use case:

  • An Instagram ad appears while browsing through Instagram.
  • User taps the CTA, which triggers an in-app webview that contains a page on our site. That page has an embedded Klaviyo form.
  • Klaviyo fails to load, leaving a hole in the page.
  • Users’ device checked: No ad blocking software installed, default Safari options. So it looks like Safari (15.4) is blocking it out of the box. That’s a LOT of users.

There needs to be a better way of handling blocked content: or at least, Klaviyo needs to be far more transparent about what may and may not work and how to handle cases where embedded forms do not work.

Asking users to disable ad blocking is just not going to wash as more and more browsers do this out of the box.

Sadly, looks like we will now have to remove Klaviyo from many of our landing pages and replace with Shopify forms.

Has anyone come up with an elegant solution?

icon

Best answer by Dov 5 August 2022, 16:32

View original

2 replies

Userlevel 7
Badge +55

Hi @Shell,

Thanks for sharing this question with us.

To my knowledge, there is nothing about Safari 15.4 that should be preventing the embed form from loading. However, there are other non-browser-specific problems that could be occurring. For example, if you have multiple scripts of Klaviyo’s onsite javascript present: 

<script type="text/javascript" async="" src="https://static.klaviyo.com/onsite/js/klaviyo.js?company_id=API_KEY"></script>

 that could prevent the form from loading. Resolving this involves having our support team remove the duplicate script(s) from your website. Here’s a thread on that topic: 

I also recommend exploring the solutions outlined in the below thread which includes signup form troubleshooting steps:

We do have a call out for internet explorer users which does have a known browser limitation with our forms:

Lastly, I would consider reviewing the code on your site, if you’re running any 3rd-party scripts on your website - that could be interfering with the ability of our forms to load. We’ve certainly come across cases like that before.

I hope you’re able to get this resolved through one of the aforementioned steps. If not, you can also reach out to our support team to have a closer look at your particular website/use case.

Thanks for being a community member.

Badge

Thanks for the response. Interesting resources there.

In the meantime, we’ve switched to using the Klaviyo addon for Shogun (in which our landing pages are constructed). This appears to circumvent the issue as I believe Shogun is talking to the Klaviyo API, rather than loading Klaviyo client-side scripts.

Reply