Solved

Klaviyo sign up form not displaying on Webflow site

  • 9 February 2022
  • 5 replies
  • 106 views

Badge

Klaviyo sign-up form not dislpaying on Webflow site.

I am having trouble viewing my sign up form on my Webflow site. I have installed the snippet code (as per Klaviyo suggested), I have made sure it’s within a container in Webflow, published it, and I am not able to see it displayed. 

  • I went to the published site in a separate tab, and I do see that the code is sitting there where it should be through “Inspect” on Google browser. 

Am I missing something? I have done this before, put Klaviyo sign-up forms on many sites, but my luck here is just not coming through. Any ideas? Thanks.

icon

Best answer by thecrocodile 9 February 2022, 21:10

View original

5 replies

Userlevel 6
Badge +54

Hi @thecrocodile

 

Welcome to our Community! We are so glad you’re here, would love to offer more insight into this! 

 

Using Embed forms are an easy way to have a form permanently planted on your site to receive subscribers regularly. Do you mind sharing what you looked for when you chose the ‘Inspect’ option on your browser. That is a great idea to when trying to figure out whether or not something is properly inserted into your website’s code. When inspecting your code to see whether or not an embed code is there, you can search in the ‘Inspect’ tab or ‘View Page Source’ > click Command + F > Klaviyo. As our Where to Post An Embed Form's Code documentation states, since the word Klaviyo is in the embed form’s code this should be a signifier of whether or not the form is there. 

 

Additionally, if you see multiple accounts API keys in your website’s code this could also be an indicator that there are multiple Klaviyo accounts linked to one website and would be another reason why an embed form would have trouble displaying, as stated in our Signup Form Troubleshooting Help Center Article. 

 

Finally, I’d suggest checking out similar topics in the Community to gain more insight! 

 

Thanks for participating in the Community!

-Taylor 

Badge

Above is the screenshot of the code snippet that I placed on my website. 

Below is the screenshot of the code sitting within a container on my website.

Within Klaviyo: the signup form is marked to be shown to all visitors without any filters set. For some reason, it does not populate on the the website. I did completely remove the code and the container within webflow and re-installed it again this morning with no success.
Thanks for your help!

 

Badge

I just re-processed through everything and made sure that I didn’t miss any steps, and it’s now working on my website. Thank you for your time. 

Userlevel 6
Badge +54

Hi @thecrocodile

 

Thank you for sharing that update with us! Do you mind sharing more insight  into what you mean by ‘re-processed’ and share you steps with us? This might help another user who is struggling with a similar issue in the future. 

 

Thank you!

-Taylor 

Badge

I went through every step to make sure I did everything correctly, I reapplied the code snippet, made sure webflow was responding accordingly, and made sure the code was at least on the website through Google Inspect. 

Solution: I noticed that my signup forms (in klaviyo) were live, but “not connected.” I went to my homepage website, copied the url and pasted it in the settings of my account. For whatever reason, that made everything work properly. I ran tests, made sure platforms were talking to each other, and all is good.

Thank you!

Reply