Solved

Sign up form (popup) not showing up on shopify store

  • 24 March 2022
  • 3 replies
  • 386 views

Badge

Hello!

I have successfully made my first sign up form campaign for my shopify store. 

The code snippet is installed correctly onto my website and shopify is connected through klaviyo.

Unfortunately the code snipped gives me this error 

“Unable to detect that signup forms are successfully installed on your site. Please view the installation documentation.”

I have tried everything in the installation as well as the troubleshooting document. But everything is correctly installed. The popup simply does not show up on my site (even in private browser).

Any ideas guys? (Below I attached my edit code portion of shopify, where my snippet is visible).

 

Thanks

 

icon

Best answer by Dov 24 March 2022, 19:25

View original

3 replies

Userlevel 7
Badge +61

Hi @HunterKlipp,

Thanks for sharing this with us in the community.

Congratulations on getting your first signup form created and ready to go!

Since you are using Shopify, there shouldn’t be a need for you to actually go into the theme file and manually insert the javascript snippet you’ve highlighted in the screenshot. You can simply remove that altogether and try re-publishing the form. Also that error doesn’t always mean the form won’t publish, so take it with a grain of salt. Even if you do see the error, I would double-check to see if the form is indeed still publishing to your site.

I recently made a post to assist another community member to troubleshoot their embed sign-up form on their Shopify site. I recommend having a look through the steps outlined in that post which might be helpful to resolve your issue. Linking that below:

You can skip over the part about searching for the embed code on your site since that does not apply to popup forms. You may have encountered some of this in the troubleshooting doc already. If you are still having difficulty after running through all of the steps in the thread above, I do recommend reaching out to our support team to have a closer look at your website to pinpoint the issue. 

Thanks for being a member of our community.

Badge

Thank you very much for the well-thought up answer. I have contacted support and hope to hear back from them soon,

I removed the code snippet and republished the form, but there is no change. Would you presume there is a conflicting bit of code in my theme.liquid file? I did have a chance to comb through and didn’t see any other javascript files or scripts in there for other popups. That is part of the reason I am so confused! Seems like nothing can fix it at the moment, but I'll remain hopeful.

(also) the green circle is filled in beside my form, which I presume mean that it is running properly. Just have no luck seeing popup from incognito browser (phone or desktop). Even after clearing cache/cookies

 

Userlevel 7
Badge +61

Hi @HunterKlipp,

Thanks for your reply.

Yes, that could very well be the case. I see you have a ticket filed with our support team - they’ll be able to assist you further from here.

Thanks for being a member of our community.

Reply