Solved

Sign up forms appearing in other embedded forms

  • 28 March 2022
  • 3 replies
  • 28 views

Badge

Hi all,

Strange thing happening here. We have sign up forms running across our site for a promotion we’re currently running. For some reason, the sign up forms are appearing in embedded forms on the page. These embedded forms are from Paperform, not Klaviyo, and the page on which it appears is excluded from the sign up form pop up.

Anyone have any idea what’s happening?

Any help is appreciated.

Best,

Reuben

icon

Best answer by Dov 1 April 2022, 20:14

View original

3 replies

Userlevel 7
Badge +61

Hi @reubenoconnell,

Thank you for sharing this with us.

To clarify, it sounds like there are two issues. On the first statement -- do you mean the Paperform embeds are appearing on pages where they’re not supposed to? If that is indeed the case, that’s not something we’re able to control directly in Klaviyo. In this case, I recommend contacting Paperform to better understand how to control their form display.

On your second point: “These embedded forms are from Paperform, not Klaviyo, and the page on which it appears is excluded from the sign up form pop up.” This sounds like an issue with the pop-up form displaying on a page you’ve explicitly asked not to target by URL? If that is indeed the case, I recommend double-checking the targeting settings for the pop-up.

If you select Exactly Matching, be sure to include the correct protocol (e.g., http:// or https://) at the beginning of your URL. 

Please correct me if I’ve misinterpreted any of this. And if you are still having difficulty, can you show us a few screenshots of the actual URL and the targeted URL for exclusion? 

Thanks for being a member of our community.

Badge

Hi @dov,

Thanks for the reply. 

To clarify, there is no issue with our Paperform embeds. The key issue which is pictured is that the Klaviyo sign up forms are appearing within the Paperform embeds (the grey box is the shadow/translucent background of the Klaviyo pop-up.

In terms of targeting, I will have a look at this. I was using the below settings:

Don’t show on certain URLs containing /corporate-enquiries (the slug of the page). I will try excluding full URL and variations now and let you know.

Best wishes,

Reuben

Userlevel 7
Badge +61

Hi @reubenoconnell,

Thanks for your reply.

You can get rid of the translucent background by disabling the overlay. If you click on the Styles tab within the pop-up form and scroll to the "Overlay Color" section. You’ll see that there are five blocks at the bottom -- for the block named "A" -- you'll want to set that value to 0 (see below.)
?name=Screen+Shot+2019-12-06+at+3.05.19+PM.png

Is that what you meant by “appearing within the Paperform embeds”, if not perhaps you can clarify further. Looking forward to hearing back from you on the URL exclusion point as well. 

Have a great weekend!

 

Reply