Solved

Images not displaying in gmail

  • 7 November 2022
  • 10 replies
  • 1717 views

Badge +2

Hi all!
When I send a test email to my Gmail email address, the images don't display.
However, when I send a test email to my friend’s hotmail email address, there I can see the images.
I don't know how to fix the problem, because if customers don't see the images, it's not great...
If anyone has the solution please?
Thanks in advance! Josie :-)

icon

Best answer by Omar 7 November 2022, 20:50

View original

10 replies

Userlevel 7
Badge +45

Hi @Josie P,

 

Congrats on your first post here.

By any chance do you have this setting on in Gmail?https://support.google.com/mail/answer/145919?hl=en&co=GENIE.Platform%3DDesktop

 

Regards,

Omar Lovert // Polaris Growth // Klaviyo Master Platinum Partner

Klaviyo - CRO - Customer Value Optimization Specialist

Badge

No, these emails have been landing right in my inbox for a very long time, years actually, and I’ve always had this issue with the images. I thought it was just my gmail account.  I’m one of the owners of the company and have just taken over managing Klaviyo and I’m finally asking the question: why does this keep happening? The more I dig I’m finding it happening in other gmail inboxes too, but I’m wondering if it’s just because I send a bunch of previews to those addresses and then gmail thinks all the duplicate-ish emails are suspicious?

And yes, this is happening through the preview emails as well. Sometimes when I change the “from email address” it will prevent it from happening in certain inboxes but not all of them.

I am looking into the dedicated domain option, but I’ve read there are other negative effects of that with other providers so it makes it tough.

Badge

Hi @Josie P,

I have been struggling with this same issue and I’ve been through several chats with support and still having trouble figuring out what’s going on. They told me it was not very common, but I’m hoping maybe you discovered something that helped and wouldn’t mind sharing what you learned. :) 

 

Thanks so much!! 

Katie

Userlevel 7
Badge +60

Hey @kmfield,

In addition to enabling the Always display external images setting in your email as @Omar mentioned, are your emails landing in spam by chance? 

When emails land in spam, all images are hidden. This is the inbox provider protecting the recipient from the content. @Spark Bridge Digital LLC talk a bit about this and touched on this possibility in a recent thread that I included below:

Are you experiencing this behavior through preview emails you’re sending yourself for testing? I’ve also seen this behavior caused by your network or corporate inbox provider blocking the images. They’ll block the images as they find it suspicious to be receiving a marketing email from the same domain. 

When this happens, it’s best to be on a dedicated sending domain and to have your network administrator/IT administrator allow-list Klaviyo within your DNS backend. 

David

Badge +1

This has been happening to me to. Klaviyo support says nothing is wrong on their end and to chat with gmail, which i’m doing now. No other companies emails clip, just mine. 

Badge +2

Hi! I’ve checked that a hundred times and there all the settings are correct! I can see images from every other company that I’m on the list for, just not from my company!

Badge

Hey guys, has anyone found the solution? I’m experiencing the same thing in my Gmail account when sending test emails to myself.

@kmfield did you try out a dedicated domain?

@alex.hong Can Klavio come up with a solution? It’s not a good look to have to create a dedicated server to use your product. 

Badge

Note: My test emails display correctly when I send them to my Gmail address from Privy or Shopify.

The send-from email address is the same, as is the content.

Klavio is the only platform where the content isn’t displaying or is considered potentially suspicious. Neither Shopify or Privy have welcome sequences, but a welcome sequence that looks ghetto isn’t great. 

Help?

Userlevel 7
Badge +58

Hi @Josie P ,

It could be an issue with the email formatting or how it is set up on your end. I would recommend checking in with Support since they can go into your account and work with you.

 

Thanks,

Alex

Userlevel 7
Badge +60

Hello @Rael Cohen,

Setting up and using a dedicated sending domain isn’t required to use Klaviyo at all. In fact, all accounts start off as being on Klaviyo’s shared infrastructure and a large number of accounts oftentimes remain on it. 

The use of a dedicated sending domain versus remaining on a shared domain is up to you and how your own DNS backend is setup. If you were previously on a shared domain or your domain had previously been authenticated on a different ESP (email service provider), then you’ll want to continue with the same practice after migrating to Klaviyo. 

If your images are being omitted and are considered potentially suspicious, and you previously were not on a shared/authenticated domain from a different ESP, this may indicate more of a deliverability issue. When this occurs, I suggest taking steps to strengthen and repair your sending reputation. 

I would advise taking a look at some of our helpful resources both in our Help Center and our Deliverability category in our Community. I’ve also included some Help Center articles that would be helpful in reviewing:

David

Reply