Solved

POP UP NOT CONNECTING TO EXISTING WELCOME FLOW

  • 5 January 2022
  • 6 replies
  • 391 views

Badge +2

I have tried and tried and tried linking my pop I created, to an existing welcome flow I created for discount for new subscribers to my mailing list.  I have tested this with my own 3 emails and no matter how much I have played with the settings I don’t get my email with the code I out on it from the welcome series flow, I get this email attached below. Please help me resolve this matter! Thanks in advance. 

 

icon

Best answer by Taylor Tarpley 5 January 2022, 22:55

View original

6 replies

Badge +2

Hi @BeenSun

 

You could create a test email if you prefer, but signing up for a list via email and being able to walk through the process to see if each feature is firing correctly is a recommend workflow. Additionally, I have seen there be duplicate Lists of the same name or Segments with the same names a Lists that has caused Flow confusion. 

 

Just adding any last possibilities to investigation that could be responsible for this issue! 

-Taylor 

Thank you so much Taylor for that information!

Userlevel 7
Badge +60

Hi @BeenSun

 

You could create a test email if you prefer, but signing up for a list via email and being able to walk through the process to see if each feature is firing correctly is a recommend workflow. Additionally, I have seen there be duplicate Lists of the same name or Segments with the same names a Lists that has caused Flow confusion. 

 

Just adding any last possibilities to investigation that could be responsible for this issue! 

-Taylor 

Badge +2

Hi @BeenSun

 

Welcome to the Community! We are so happy to have you! Sorry to hear about your issue, would love to offer a hand. 

 

I think @Bobi N. brings up a great point that Double Opt in does require a second confirmation before it adds a subscriber to the list. However, if you have been confirming your subscription a second time, per your screenshot, can I ask when you turned your Flow live, meaning all the messages in your flow were turned from draft to live before you turned on your form? It could be that your Flow is still in draft form or was turned live after your you submitted the form. 

 

Finally, a third option you could check would be if your Flow is connected to the correct List. I would dive back into your Flow and ensure that what triggers your Flow, on the top right side of your Flow builder screen, is being added to the same List as that’s synced to your form. 

 

Thanks for participating in the Community!

-Taylor 

Hello Taylor, thank you for the welcome, I have made sure all of my flow emails are live, I have also ensured that my flow is connected to the same list as well. Thank you for the info, I do want to ask is there a way to test this when I get done revising the opt in setting without me using my email? 

Badge +2

@BeenSun

This is probably because you haven’t turned your double opt in option off so it asks you to confirm your subscriptuion (Double Opt-In setting). So if you want to remove this, go to the list that you set as subscription list for this form, open the list and go to settings. On the bottom you will see double opt in and single opt in.. double opt in is set as default so you will have to chnage it and save.

Thank you so much Bobi, I will try this!

Userlevel 7
Badge +60

Hi @BeenSun

 

Welcome to the Community! We are so happy to have you! Sorry to hear about your issue, would love to offer a hand. 

 

I think @Bobi N. brings up a great point that Double Opt in does require a second confirmation before it adds a subscriber to the list. However, if you have been confirming your subscription a second time, per your screenshot, can I ask when you turned your Flow live, meaning all the messages in your flow were turned from draft to live before you turned on your form? It could be that your Flow is still in draft form or was turned live after your you submitted the form. 

 

Finally, a third option you could check would be if your Flow is connected to the correct List. I would dive back into your Flow and ensure that what triggers your Flow, on the top right side of your Flow builder screen, is being added to the same List as that’s synced to your form. 

 

Thanks for participating in the Community!

-Taylor 

Userlevel 7
Badge +42

@BeenSun 

This is probably because you haven’t turned your double opt in option off so it asks you to confirm your subscriptuion (Double Opt-In setting). So if you want to remove this, go to the list that you set as subscription list for this form, open the list and go to settings. On the bottom you will see double opt in and single opt in.. double opt in is set as default so you will have to chnage it and save.

Reply