Solved

Email Flow is not sending

  • 28 May 2023
  • 6 replies
  • 251 views

Badge +1

I imported emails into a list and created a flow of emails. But the flow is not sending emails to the people on the list. I cannot change the trigger where it says “People will enter this flow when they subscribe”, but I added a Flow filter (please see the pic). What am I doing wrong? 

In the list, the Opt in process is set to “Single opt-in” 

 

icon

Best answer by Bobi N. 29 May 2023, 07:19

View original

6 replies

Userlevel 7
Badge +42

@roorji 

I may be wrong but from what you said you first uploaded people to the list and then created the flow and turned live..

List is triggering a flow as it says in the trigger, when someone subscribes to a list. So if you added the subscribers to the list before you set the flow live they wont be triggering the flow.

So what you need to do is create a flow and set it live and only then upload people to the list.

Badge +7

Hi @roorji What Bobi has mentioned is correct.

There is a way to send emails to these subscribers though, what you can do is back-populate the flow. Here is an article which will help understand this more https://help.klaviyo.com/hc/en-us/articles/115002779231

I would choose so that all these subscribers would start at the beginning of the flow. 

  • Schedule recipients relative to when you click back-populate

Hope this helps :) 

Badge +1

Hi @jocelyn8. I’m wondering if you have any more insight on this issue. I have a welcome flow set triggered by newsletter sign ups and my flow is not going out. I have back populated and set to single opt in. Anything I’m missing?

Badge +7

Hi @albail22 do you have any time delays before the first email or any flow filters in place?

 

Hi @jocelyn8 , I am facing the same issue as mentioned in this thread

I have checked that
1) There are no delays
2) The emails that i used to signup are present in the newsletter list
3) The trigger for the welcome email is signing up for the newsletter
4) There are no filters that could prevent the email from sending as it mentions “There are no filters and the email qualifies for the flow”
5) I have checked the spam folder
6) Tested with several emails

I hope that I could get further assistance from you or the Klaviyo Team.

Kind regards,
Sidney 

Userlevel 7
Badge +60

Hey @firefox363 

I believe my colleague David responded to this question in another post for you. Here is the link for you to check out his response: 

Hope this helps!

Reply