Solved

Post Purchase Review email "Write a Review" button link not working

  • 13 September 2023
  • 2 replies
  • 231 views

Badge
  • Contributor I
  • 0 replies

I have setup a flow to send a “Post Purchase Review”

The email sent from Klaviyo has a button “Write a Review”

The URL in this button is “{{ organization.url|trim_slash }}/products/{{ item.product.handle }}#reviews”

The URL goes to our “Collections” page not a review page.

What URL should the button go to?

I have tried the following URLs and none have worked:

{{ organization.url|trim_slash }}/products/{{ item.product.handle }}#reviews

{{ organization.url|trim_slash }}/products/{{ item.product.handle }}

{{event.order_items.0.product_review_link}} 

icon

Best answer by David To 13 September 2023, 21:42

View original

2 replies

Userlevel 7
Badge +60

Hello @DLW,

Welcome to the Klaviyo Community! 

What’s the trigger for your flow? Is it Fulfilled Order or Ready for Review?

Based on the button URL variable you’ve shared, I’m assuming it’s the Fulfilled Order. If this is the case, then it sounds like you didn’t add the anchor tag to your site’s product page code yet. This is mentioned in the Link customers to the review area on a page section of our How to create a product review flow Help Center article.

I also noticed you mentioned, you had said “button”. Typically, in the prebuilt flow, the “write a review” is actually a hyperlink rather than a button. Did you happen to create a button outside of the dynamic table block? 

If so, then you’ll actually need to reformat the pre-existing URL link. When housed within the dynamic table block, the {{ item.product.handle }} is actually being looped to account for users purchasing multiple products. Instead, you’ll want to leverage the {{ event.extra.line_items.0.product.handle }} variable. You may also need to create a series of buttons to account for the potential of users with multiple items and utilize some show/hide logic to show or hide the buttons when applicable. 

I hope this helps!

David

Badge +2

Hello

Whether i use {{ organization.url|trim_slash }}/products/{{ event.extra.line_items.0.product.handle }} or 

{{ organization.url|trim_slash }}/products/{{ item.product.handle }} - it shows 404 Error. 

why is this happening?

Can anyone help me out with this!

Reply