Dynamic Product Feed Not Populating In Emails

  • 15 December 2022
  • 4 replies

Badge +1
  • Contributor I
  • 2 replies


I am unable to add a dynamic product feed to an email. 

It is not populating.

My products are there as I can add a static selection.


Thanks in advance.


Best answer by David To 15 December 2022, 16:48

View original

4 replies

Userlevel 7
Badge +60

Hello @Ludo,

Welcome to the Klaviyo Community!

I would first double check to see if your products have inventory and are considered “published” by Klaviyo. I explained this a bit in the Community post below:

I hope this helps!

Badge +1

Hi David,

Thanks for replying.

I have found the Product tab and found all seems in order. My unpublished products are ones that I do not currently have any stock of. I have over 300 stock lines, a lot of categories and I am using WooCommerce if that is relevant in any way. 

Userlevel 7
Badge +60

Hey @Ludo,

When you say you’re “unable to add a dynamic product feed to an email” and “It is not populating”  but you’re able to add a static selection, are you by chance previewing the email? It’s expected behavior in a product block that when selecting the dynamic option and your desired product feed, you won’t see any products populate yet. This is because they should theoretically appear dynamically based on each recipient. For this reason, when using the dynamic option, you’ll only see products appear when previewing the email. 

If you are previewing the email and not seeing the products populate, have you by chance selected to populate the product block with a product feed that may contain all unpublished/out of stock products? As mentioned in the thread prior, products considered unpublished for being out of stock would not display in emails. 

You may also find our How to insert a product block and How to use product feeds and recommendations Help Center articles helpful as they explain how product feeds work and how to us either the dynamic or static function of our product blocks.


Badge +1

Hi David,

Finally worked it out. In the product feed removed the category filter and all is good now. 

Not quite sure why it worked as the category filter was set to include all products.

Thanks for your help :)