Woocommerce integration: Unable to Access API with Credentials Specified

  • 10 February 2021
  • 15 replies

Badge +2
  • Contributor I
  • 4 replies


I’m having issue with the integration of my WooCommerce with Klaviyo. 

I generated an API key with read,write permission. I have my consumer key and consumer secret wich I paste in my integrations settings. But when I click « Connect to WooCommerce» this message appear « Unable to access API with credentials specified». I’m stuck here and don’t jnow what to do




Best answer by nate-klaviyo 10 February 2021, 20:55

View original

15 replies

Badge +3

Hi there!

The WooCommerce integration settings form makes a few test API calls using the provided store URL and consumer key and secret. If the calls fail or returns an unexpected response, then an error is displayed. Often times the culprit is a firewall or other plugin interfering with the API.

One check you can perform is to make a test API call yourself and inspect the response. You can do this by navigating to a URL in your browser with the below structure, filling in the placeholders with the appropriate information:



For example, if my store URL was “” and my key and secret are “my-consumer-key” and “my-consumer-secret” respectively, the URL would look like this:


If you paste the resulting URL into your browser, you should see product data presented in JSON format:


Can you give this a try and let me know the results?

Badge +2


just tried, this the result: 


Badge +3

The WordPress plugin also creates some custom API endpoints that are tested by the settings form. These checks could also be triggering a settings form error if they are sending back unexpected results. What do you see for this API call (filling in placeholders where appropriate)?


Badge +2

That’s the response I get 


Badge +2

@nate-klaviyowhat would be the next step ?

Badge +3

This error means that the Klaviyo WordPress plugin is not installed or another plugin is interfering with this API endpoint. Have you gone through the setup process for the Klaviyo WP plugin?

If the plugin is installed and this behavior persists, I would recommend opening a support ticket so we can work with you more closely - we may need to work with your IT/hosting provider to track down why this API endpoint is unavailable.

Badge +2

The Klaviyo wordpress plugin as been installed. I am following every step in the « How to integrate with WooCommerce» article. 

I have written 3 times to the Klaviyo costumer support since monday and I still no response. 

I will look is another plugin is interfering. 

Thank you 

I am experiencing the same exact problem! So frustrating. @Mar  were you able to find a solution? Thank you!


I will add that my Klaviyo account was previously connected to my Shopify store, and now I am migrating over to Worpress/Woocommerce….

I deleted and reinstalled the Klaviyo plugin, but I still get this error message. so frustrating! What to do?


Badge +2

The same here :/ 

I can access : {store-url}/wp-json/wc/v3/products?consumer_key={consumer-key}&consumer_secret={consumer-secret} 

but in klaviyo panel I get 403

Badge +1

Just adding my name to the list. We are having the same problem, but I can access the products using wp-json. I tested changing a digit in the consumer key and get unauthorized back, so I’m sure it is correct. 

Badge +1

We’re experiencing the same issue. I can access each of the API endpoints above - core endpoint and the product count endpoint created by Klaviyo.


Has anyone discovered a solution?  Thanks,


Badge +1

For me, the problem turned out to be that the previous developer had directed the site through SiteLock, who were blocking the Klaviyo request as an unidentified bot. 

Badge +2

im getting this problem also and have tried deleting app and reuploading. At first it says the plug in is out of date but its the latest version of 3.0.1 and I’ve reuploaded it twice now. 

Your Klaviyo plugin for WooCommerce is out of date

There is a new version of the Klaviyo plugin available in the WordPress plugin directory. For upgrade or troubleshooting help, please see here.

If you just updated your plugin, you may need to refresh this page. It can take several minutes for the changes to reflect in Klaviyo.


now it is also saying underneath 


Unable to access API with credentials specified.

Badge +4

Has anyone found a solution to this yet? I have the same issue and the same result as @kanec but I still can’t integrate Woo to Klaviyo