Solved

All my emails are tagged "Email Never subscribed"

  • 15 June 2023
  • 6 replies
  • 2729 views

Badge +1

I’m having a problem where every email in my system says “Email - Never subscribed”, but they have subscribed and opted in. Does anybody know why it does this? How do I fix this?

 

 

Also, why is it allowing me to send emails and still have this tag on it? I’m just not understanding what happened. This wasn’t an issue a week ago.

icon

Best answer by chloe.strange 15 June 2023, 22:38

View original

6 replies

@David To excellent, thank you for that suggestion. 😀

Userlevel 7
Badge +60

Hey @scottm,

Since Make is a third-party app that developed their own connection with Klaviyo, I would recommend reaching out and speaking with them for more clarity on the API endpoint being used. 

I suspect, since consent doesn’t appear to be passed, chances are they aren’t utilizing the Subscribe Profiles endpoint - an updated endpoint to the one that @chloe.strange mentioned prior.

David

@chloe.strange I have this same question, only I am using the Make.com integration to “Create and Add a Profile to a List”

I believe that, of the Make modules, this is the correct one to use. However, when new profiles are created via that module, I get the same “never subscribed” warning flag, as described above.

Is there another preferred method for adding new profiles via Make (and indicating that the user has consented to marketing)? Thanks!

Userlevel 7
Badge +60

Hey @HFJoel,

Thanks for bringing this up and helping other Klaviyo members who may be wondering the same thing!

Glad to have you participating in our Community!

David

Badge +1

That is why I wanted to bring this up in the community too. In case somebody else had the same question.  Thank you for answering it.

Userlevel 5
Badge +29

Hi @HFJoel

Thanks for being a part of our community! I see that you had a support ticket open on this topic. I’m sharing the solution below in case it helps others in our community:

Context:

  • you have confirm that you have their permission to email them
  •  your developers set up a custom integration

Solution:

In order for these people to feed in with full consent, you will want to work with your developers to set up the subscribe endpoint: https://developers.klaviyo.com/en/v1-2/reference/subscribe. If the member endpoint is what is being used currently, that will just feed people in, it will not subscribe them with full consent.
 
Since it is a custom API feeding these people in, we do not have access to review/edit that code. We recommend connecting with your developers and sharing these profiles to showcase that they are not being subscribed or added to your lists how you are hoping. 

 

~Chloe

Reply