Solved

Embed Form Not Showing

  • 17 January 2024
  • 6 replies
  • 231 views

Userlevel 1
Badge +2

My embed form suddenly stopped working.  I do not have popup blockers working and I stripped all but the essentials from the page trying to get it to work.   Any clues?

And, yes, in the code below I changed out my real public API key and real form ID.
 

<!DOCTYPE html>
<html lang="en">
<head>
<script
type="text/javascript"
src="https://code.jquery.com/jquery.js"
></script>
<script
type="text/javascript"
src="https://code.jquery.com/ui/1.11.4/jquery-ui.js"
></script>
</head>
<body class="sponsor_body">
<script
async
type="text/javascript"
src="https://static.klaviyo.com/onsite/js/klaviyo.js?company_id=ABC123"
></script>
<div style="padding: 40px">
<div id="MainContent">
<div class="klaviyo-form-WXYZA"></div>
<div
class="maincontent"
style="
position: relative;
width: 100%;
padding: 23px 30px;
box-sizing: border-box;
"
>
<div class="content_max">
<div class="page_title">
Interested in Buying Multiple Training Packages for
Your Staff?
</div>

<p>
If you're ready to buy now, and it is between 8:30
and 5:30 monday through friday, then give our Client
Relations Team a call at (1-800) 555-1212
</p>
<p>
Tell whoever picks up you want to buy multiple
Training packages.
</p>
</div>
</div>
</div>
</div>
</body>
</html>

 

icon

Best answer by Taylor Tarpley 5 February 2024, 21:51

View original

6 replies

Userlevel 7
Badge +60

Hi there @rlscsi

 

Welcome to the Community! Great job troubleshooting so far! 

 

To confirm, you have already investigated for conflicting CSS in your website’s code and didn’t find anything? If so, you mind testing if any of these options allow your form to display successfully again:

  • Even though you don’t have popup blockers interfering, I’d investigate if you have anti-viral software, plugin, application an extension you’re running that could interfere 
  • Check if you have two Klaviyo web tracking snippets connected to two different Klaviyo accounts

https://community.klaviyo.com/sign%2Dup%2Dforms%2D38/signup%2Dform%2Dnot%2Dworking%2Dall%2Dthe%2Dtime%2D2082

 

Additionally, if none of these options illuminate the issue, do you mind sharing what recent changes you made around the time that the form stopped working? That could help better narrow down the potential issue.

 

Thanks for participating in the Community!

-Taylor 

Userlevel 1
Badge +2

Thank you for responding.

I’m not sure how I would do this (“Check if you have two Klaviyo web tracking snippets connected to two different Klaviyo accounts”) but what you see in my code is a stand-alone HTML file, so there is no other influence on it.

For that same reason, there should be nothing that any changes, save IIS (and there were none), were made that should affect anything.

Userlevel 7
Badge +60

Hi there @rlscsi

 

Happy to help! 

 

You can do so by inspecting the backend of your website’s code and looking to see if there are two .js scripts on your account.  You can do so by navigating to your website, clicking ‘View Source’ and clicking ‘Control + F and searching ‘Klaviyo’. You can then see whether there are only one or more codes that look like below:

<script type="text/javascript" async="" src="https://static.klaviyo.com/onsite/js/klaviyo.js?company_id=PUBLIC_API_KEY"></script>

 

Additionally, to confirm your developer investigated to see that there is none of the following as well: anti-viral software, plugin application or an extension?

 

-Taylor

Userlevel 1
Badge +2

Taylor,  are you saying there SHOULD or SHOULD NOT be two scripts?

Userlevel 1
Badge +2

To answer your question, however, there is only one script.

 

<script async type="text/javascript"
  src="https://static.klaviyo.com/onsite/js/klaviyo.js?company_id=APIKEYISHERE"></script>
 
Userlevel 7
Badge +60

Hi @rlscsi

 

There should only be one. More than one is what can cause issues on accounts! 

 

However, if you have asked your developer to ensure there are no anti-viral software, plugin application or an extension added either to your site. Then there might be a deeper issue here and I would recommend reaching out to our Support team to investigate this issue further! 

 

I’m very sorry that we weren’t able to find a solution here, but I know our awesome Support team would love to work with you! 

-Taylor 

Reply