Solved

Checkout event is not working

  • 19 July 2021
  • 5 replies
  • 736 views

Badge +2

Hi, 

Its been many days now and i am unable to connect with any of the klaviyo support. I also emailed to klaviyo but unfortunately i didn’t got any response. 

 I am facing an issue that needs immediate resolve as my abandoned cart flow is not working and the checkout event is not been triggered properly. Further i purchased the sms plan and it shows the same error that “We have not yet received any Started Checkout events from WooCommerce”. I have checked again and again all my settings and integrations with woocommerce but still no resolve. 

I know klaviyo is a strong platform and i shifted from mailchimp to klaviyo but this issue is testing me to its best. I hope i would get some help from the klaviyo team. 

Looking Forward 

 

icon

Best answer by Dov 30 July 2021, 15:45

View original

5 replies

Userlevel 7
Badge +59

Hello @Muhammad Talha,

It appears that you were able to receive an answer from our Support team regarding your WooCommerce Checkout issue. I’m also happy to hear that the issue suggested was able to resolve your issue! To summarize for other Community members who may be following along or have run into a similar issue, the Started Checkout event not triggering was caused by conflicting Klaviyo.js scripts on the website. This was caused by the inclusion of an additional space when declaring the Public API Key / Site ID when configuring the Klaviyo WooCommerce Plugin; similar to what @Dov had previously mentioned in the following Community post:

Have a great day!

David

Userlevel 7
Badge +61

Hello @Muhammad Talha,

Thanks for sharing this with the Community.

Can you confirm you have downloaded the latest version of the Klaviyo extension for WooCommerce? The Started Checkout event for WooCommerce is controlled by the plug-in. Instructions for downloading the update are available here. Also you’ll need to confirm that you have Read/Write permissions enabled under the REST API permissions.

If you do have the latest version of the plug-in and you are still experiencing an issue logging the Started Checkout event, I would suggest uninstalling the plugin and re-installing it once again. I would also try disabling any other plug-ins you have active during this test as it’s possible they are interfering with the ability of this plug-in to capture the Started Checkout events. 

Lastly, can you confirm if your checkout page (not billing) is a third party app or native to Woocommerce?
 

Badge +2

Hey ! i yesterday talked to klaviyo support and i told them the issue that my started checkout trigger is not working all the other triggers are working perfectly. They said that you are using third party multistep checkout for woocommerce that's why it is not triggering so i shift to default woo commerce checkout as he said the Triger will trigger the stated checkout events with default woo commerce checkout. So i did what he said and now it is also not working on default checkout so i am blank now what to do i am unbale to send abandoned cart emails and sms to customers which is not bearable for me at this stage please look into this matter or i have to choose another platform then !  

Badge +2


Hey i have updated the klaviyo plugin for woocommerce and then also checked the restAPI it was set to read/write permission already and then i uninstall plugin as well and then insall it on my woocomerce. Well i am  using a multistep checkout plugin for woocoomerce 
i can’t disable it because it is running and orders are coming. Is this multistep checkout plugin that is making hurdle for started checkout trigger to click? or something else … My users on website are mostly guests not logged in customers . 
The issue is still there it is not capturing the started checkout trigger and i am unbale to send abandoned cart emails and sms. Please look into this as i need this abandoned option urgently.

Looking Forward...

Userlevel 7
Badge +61

Hello @Muhammad Talha,

I left a note in the thread below that speaks to this issue directly for a customer who ran into the same problem. Please have a look there for more potential fixes for this issue.

 

Reply