Solved

403 authorization error Woocommerce

  • 13 June 2022
  • 5 replies
  • 72 views

Badge

Hi how are you?

We have a problem to connecet Klaviyo with Woocommerce. We get this errore: 403

icon

Best answer by alex.hong 17 June 2022, 20:50

View original

5 replies

Userlevel 6
Badge +52

Hi there @Siyaa,

Welcome to the Community.

Hope you are well. 

Please login to your WooCommerce Admin page and check the following:
 


Unfortunately, unless your WooCommerce is connected through an integration, we won't be able to fully troubleshoot on our end.

 

Since this pertains to a console warning/error, I would suggest reviewing your site code to see if there were any other additional codes on the website that may be impacting the Klaviyo.js preventing the signup form from rendering. In addition a 403 or 404 errors indicate that the access to those scripts has been forbidden or blocked by the requested server. This is usually the result of a permission issue which is another area I would suggest checking up on!

If you need further assistance pertaining to your site code and further diving into this error, I would recommend working with your developer or reaching out to a Klaviyo Partner who can provide a more comprehensive review of your site code.

 

Hope that helped,

Alex

Badge

Hi, 

 

thank you for your reply, the error 403 appears with any type of setting. We use Siteground as a server.

Userlevel 6
Badge +52

Hi @Siyaa,

It could be that your requests are getting blocked by Siteground. Since there are a multiple amount of factors that might be affecting this, I would recommend opening a support ticket with both Klaviyo support and Siteground so that those respective parties can take a deeper look into your account that we cannot do in the Community.

Apologies for the inconvenience,

Alex

Badge

Hi, 

 

I have already contacted Siteground support and they warned me that the server is not blocking Kaviyo. Here is the answer:

 

ITALIAN

L'ho testato da parte mia impostando un agente utente personalizzato sul mio browser in questo modo simulando l'accesso da Klaviyo/1.0 e non è stato bloccato:

82.118.240.146 www.siyaamoda.com - [13/Jun/2022:14:37:15 +0000] "GET /en/ HTTP/2.0" 200 0 "-" "Klaviyo/1.0" | TLSv1.3 | 3.640 3.640 3.639 MISS d NC:000000 UP:SKIP_CACHE_SET_COOKIE82.118.240.146 www.siyaamoda.com - [13/Jun/2022:14:37:16 +0000] "GET / HTTP/2.0" 200 41441 "-" "Klaviyo/1.0" | TLSv1.3 | 2.277 2.323 2.324 MISS d NC:000000 UP:SKIP_CACHE_SET_COOKIE


Il codice di stato HTTP 200 indica che la richiesta ha avuto successo.

Non sono stato in grado di trovare blocchi sugli indirizzi IP che Klaviyo ha utilizzato per inviare richieste al sito e l'agente utente non è bloccato per impostazione predefinita.

ENGLISH

I tested it on my part by setting up a custom user agent on my browser like so simulating logging in from Klaviyo / 1.0 and it wasn't blocked:

82.118.240.146 www.siyaamoda.com - [13 / Jun / 2022: 14: 37: 15 +0000] "GET / en / HTTP / 2.0" 200 0 "-" "Klaviyo / 1.0" | TLSv1.3 | 3,640 3,640 3,639 MISS d NC: 000000 UP: SKIP_CACHE_SET_COOKIE
82.118.240.146 www.siyaamoda.com - [13 / Jun / 2022: 14: 37: 16 +0000] "GET / HTTP / 2.0" 200 41441 "-" "Klaviyo / 1.0" | TLSv1.3 | 2,277 2,323 2,324 MISS d NC: 000000 UP: SKIP_CACHE_SET_COOKIE

HTTP status code 200 indicates that the request was successful.

I have not been able to find blocks on the IP addresses that Klaviyo used to send requests to the site and the user agent is not blocked by default.

 

 

Thank you

Userlevel 6
Badge +52

Hi @Siyaa,

This is going to be an issue you will have to troubleshoot on your end. A 403 Authentication error must be dealt with client side to disable and fix whatever might be blocking calls. One additional option you can try is allow-listing the agent id as mentioned in this Community post: 

Thanks,

Alex

Reply