Solved

ACTION REQUIRED] Klaviyo Magento 2 extension update

  • 9 May 2024
  • 1 reply
  • 141 views

Badge +3

Hi all,

I recently received this email:

Klaviyo will retire our legacy v1/v2 APIs on June 30th, 2024. All code using these legacy v1/v2 APIs needs to be updated, and the following accounts are currently using our legacy APIs.

I was notified that my account will be affected by this.


We did not update any code or API, rather our team migrated to newer version of Magento i.e. 2.4.7, after this migration, we received the following email.

Klaviyo will retire our legacy v1/v2 APIs on June 30th, 2024, and your Magento 2 integration will be impacted unless you upgrade the extension. Extension versions using Klaviyo’s legacy APIs will no longer operate as expected after the retirement date.

You need to upgrade your Magento 2 extension before June 30, 2024

Now, I want to confirm:
a. Do I only need to upgrade to the latest extension of Klaviyo and the Legacy API issue will be resolved?
b. Is this upgrade going to affect my current lists, segments, flows etc?

icon

Best answer by ArpitBanjara 9 May 2024, 10:28

View original

1 reply

Userlevel 2
Badge +5

Hey @USMarketer 

From what I know and its best if you connect to Klaviyo live chat support and confirm this,

  1. Yes, for Klaviyo pre-built integrations you simply have to update the plugins to transition to the latest API. If you are using any external apps, Klaviyo has already contacted them, and they will do the changes on their own end and you don’t need to change anything..
  2. Well that depends, I would suggest going through this article that compares between V1/V2 and the new endpoints - https://developers.klaviyo.com/en/docs/apis_comparison_chart.

I hope this helps.

 

Best,
Arpit Banjara

Reply