Coupons Tab is not showing

  • 28 July 2021
  • 4 replies

Badge +3

Yesterday, we’ve integrated two new shopify stores with klaviyo and give the manager roles to one of our staff to create flows, but the Coupons Tab on the menu is not showing at all. Did klaviyo got a new update? Where can I create klaviyo coupons now?


Best answer by Dov 29 July 2021, 15:05

View original

4 replies

Userlevel 7
Badge +61

Hello @Roanne,

Thanks for sharing your question with the Klaviyo Community.

With manager-level role permissions, the coupons tab should still be accessible (as outlined in our user management and privileges documentation). I suspect this may be an issue with the browser or a plug-in interfering with the ability of the coupons tab to display. Can you try accessing it again using a separate and incognito browser? I also recommend disabling any firewalls. If you’re still having trouble, can you send us a screenshot of what you’re seeing? Thanks!


Badge +3

Hello @Dov,

Thank you so much for your reply. Here are some of the screenshots that I took to show you the issue of the Coupons tab disappearance.

This is from the usual browser with only 2 Chrome extension added which are for screenshots and grammar checking as you can see.

This one is from incognito browser, same with above, no Coupons tab:

This 3rd screenshot is from my other account which are the most recent before the new accounts I created that has the Coupons Tab:

Also, this is the role assigned for each account:

Even the Admin role has more privilege than the Manager role, the Coupons tab is missing.

Hope you’ll be able to explain the issue to me.


Userlevel 7
Badge +61

Hello @Roanne,

Thanks for your reply.

The Coupons tab will only be available by default if you are using our Shopify, Magento 1, or Magento 2 integrations, and if you've just added your integration and it has not synced yet the tab may take some time to appear.

Additionally, depending on your integration, you may need to toggle on uploaded coupons in order to view the Coupons tab in your Klaviyo dashboard.

To find this setting, navigate to Account > Settings > Profile Maintenance. Toggle on the Uploaded Coupons option. 


Once you enable uploaded coupons, you will see a corresponding tab in Coupons

Badge +3

It works. Thank you, Dov!