Solved

Integration to Magento

  • 28 May 2021
  • 1 reply
  • 71 views

Badge

I just took over as site manager for a eCommerce company.  I have run into a few odd occurrences in getting onboarded here where settings in programs beyond Klaviyo were adjusted preventing them from working as intended.  Klaviyo has been used for several years, but was not functioning when I started last week.

I was receiving error messages when trying to confirm the Integrations password / API Keys had been changed and after re-running the set up in Magento and receive the following error message:

We received a 401 authentication error. Please ensure your Magento server supports HMAC-SHA1 signatures for OAuth authentication and that your credentials are correct.

I’m not sure at this point were to look, or what additional settings were changed.

icon

Best answer by david.to 28 May 2021, 20:35

Hello @Jamie Rex,

Since the error message provided indicates a 401 Authentication issue, I would recommend double checking your Magento user role permissions and ensure you have the proper permissions to create this connection. If that doesn’t solve your issue, next steps I would recommend would be to create a new user with full resource access per the How to Integrate with Magento 1.x (CE and EE) article to connect to within Klaviyo. 

One more area to check would be to ensuring that your Magento integration is on the latest Klaviyo extension version. Klaviyo's latest extension for Magento 1 is v.1.7.9, updated February 2020. If you are running a previous version of this extension, you can update and download the newest version here

After checking the user role permissions and/or creating a new user, remember to navigate back into Klaviyo to update the Magento integration settings for these new updates to take effect. 

Hope this helps!

David

 

View original

1 reply

Userlevel 6
Badge +4

Hello @Jamie Rex,

Since the error message provided indicates a 401 Authentication issue, I would recommend double checking your Magento user role permissions and ensure you have the proper permissions to create this connection. If that doesn’t solve your issue, next steps I would recommend would be to create a new user with full resource access per the How to Integrate with Magento 1.x (CE and EE) article to connect to within Klaviyo. 

One more area to check would be to ensuring that your Magento integration is on the latest Klaviyo extension version. Klaviyo's latest extension for Magento 1 is v.1.7.9, updated February 2020. If you are running a previous version of this extension, you can update and download the newest version here

After checking the user role permissions and/or creating a new user, remember to navigate back into Klaviyo to update the Magento integration settings for these new updates to take effect. 

Hope this helps!

David

 

Reply