Solved

Sending domain not sending from domain I set up

  • 21 October 2023
  • 1 reply
  • 41 views

Badge
  • Contributor I
  • 2 replies

I have set up and verified my sending domain. I elected for subdomain.rootdomain.com as my sending domain, however, I receive the email from rootdomain.com instead of subdomain.rootdomain.com as the from address.

I am confused as in the past I have configured sending domains as subdomain.rootdomain.com and it would appear as such in the inbox. 

 

 

icon

Best answer by Taylor Tarpley 23 October 2023, 18:59

View original

1 reply

Userlevel 7
Badge +60

Hi there @pile

 

Welcome back to the Community! Happy to help! 

 

Glad to hear you’ve set up a dedicated sending domain! 

 

I think the issue here might lie with confusion between a dedicated sending domain and the sending address domain. Is your default sender address in your Organization tab of your Account listed as ‘newsetter@rootdomain.com’ for instance? As our documentation sates, this is a great friendly sending address domain! 

 

The “sending domain” you establish when setting up a dedicated sending domain will have a subdomain associated like ‘send.storename.com’. Essentially, this helps Klaviyo to route things back to the root domain - ‘storename’. For this reason, using and seeing your root domain for your sending address a.k.a what you saw in the ‘reply-from’ address is correct if you have it stated that way in your ‘Organization’ tab! In fact, using your sending domain ie. send.storename.com as your sending address domain would actually cause issues in the future! 

 

Finally, I would make sure to check out our how to ramp and warm your sending infrastructure documentation to set you up for deliverability success as your DSD is new! 

 

Hope this helps!

-Taylor  

Reply