Solved

Update credit card information not working (always in progress)

  • 26 August 2022
  • 6 replies
  • 209 views

Badge +1

Hi,

We are trying to update our account credit card information to stop using the free tier and get more active accounts and emails.
 

But, when updating the credit card information and clicking on the update button, nothing happens. The button has a in progress indicator and it never stops. There are no error messages.

This is kind of urgent since we need to unblock our emails.

I submitted a ticket to support, but still no response after a few hours.

Thanks.

icon

Best answer by alex.hong 26 August 2022, 22:33

View original

6 replies

Userlevel 7
Badge +58

Hello @StephaneB ,

Apologies for the inconvenience you are facing with updating your payment info. 

We do not have access to your account in the Community so I can only offer general troubleshooting info like restarting the process and to double check all payment details are correct (no spaces inbetween digits, correct addresses, etc), and to clear ur brower’s cookies and cache and try again.

I have let the Support team know about your ticket so hopefully the issue is resolved.

 

Thank you for your patience,

Alex

Badge

having the same issue on an urgent email send so frustrating as a huge amount of time has been spent updating the contacts - go to send the urgent email and cant upgrade ? 

 

Badge +1

I am having the exact same issue! come on klaviyo, help your customers! This is terrible

Badge +1

I got the same problem! It’s embarrassing for an software like Klaviyo.

 

I‘ve launched new products and can’t inform my newsletter members anymore cause my plan reached the limit of sendet emails!

Userlevel 7
Badge +58

Hey there @wholeheartedrach @Tanisha @Joel Lücking ,

Our engineering team has reported this as a bug and a fix in the meantime has been to press [Enter] on the keyboard to get around the issue, the bug is affecting how the browser registers the button click via the mouse.

We also received updates that this error should have been fixed. 

 

Thank you,

Alex

Badge +1

Yes it’s fixed for me, I tried again and it was successful 👍🏻
 

thanks 

Reply