Solved

Why sender name is displayed in brackets?

  • 5 March 2021
  • 5 replies
  • 57 views

Userlevel 1
Badge

I noticed that sender name is wrapped in brackets when email arrives to inbox.

Why this is happening?

 

This is how the sender name is defined on the account settings page:

 

and this is how it is rendered in Gmail:

 

and it gets even worse when email agent tries to escape brackets.

 

 

icon

Best answer by Dov 13 April 2021, 19:39

View original

5 replies

Userlevel 5
Badge +3

Hi @mantrasan,

So I’m unable to replicate the behavior and can’t say that I’ve seen this specific case before. Are you still seeing the quotation marks present? If you are, could you let us know because I’m unable to replicate so this may already be resolved. If that is the case, can you let us know if you made any changes since you first noticed this?

Thank you. 

 

Userlevel 1
Badge

This is not fixed.

I can repetitively replicate the issue now - it happens when a comma is used in the sender’s name.

Please fix this.

Userlevel 5
Badge +4

Hi @mantrasan ! It looks like this is something Gmail adds on their end, which means you wouldn’t be able to control that from within Klaviyo. It looks like others have run into this in the past: https://support.google.com/mail/thread/7117651?hl=en 
 

I’d recommend trying out the methods in that thread to see if they fix this within your inbox. You can also try sending to a different Gmail inbox to see if this happens to everyone, or just in your inbox. 

Userlevel 1
Badge

Hi @elisegaines|! Thanks for your suggestion. As I have stated above this is not related to Gmail as it happens an all email agents I could test it against. This is your system adding “” around sender name when a comma is used.

 

You can easily test it yourself by adding a comma in the senders name in Klaviyo and send it to any given inbox.

 

I found a way around it by altering a sender name, but its something worth fixing.

 

Userlevel 6
Badge +5

Hi @mantrasan,

Thank you for sharing your solution with the Community and I am glad to hear that you were able to resolve this.

Additionally, sometimes this issue can occur if the name is copied and pasted and, as a result, invisible characters are carried over into the sender name. The easiest fix is to retype the name label letter by letter and avoid copying and pasting it from somewhere if that’s what was done originally. Hope this helps!

Reply