Solved

Email syntax error in back in stock

  • 18 August 2022
  • 4 replies
  • 69 views

Badge +2

Hi Team,

 

was just looking at my back-in-stock flow (standard instal) and I can see that I have a bunch of emails that were skipped due to email syntax error but these emails are receiving campaigns etc.

 

I have had a search but can't seem to find a fix for this can anyone shed some light on this for me

 

Thanks

icon

Best answer by getlikeminded 23 August 2022, 04:15

View original

4 replies

Userlevel 7
Badge +61

Hi @getlikeminded,

Thanks for sharing this question with us.

A syntax error refers to one of the dynamic tags within the template that you are trying to use to populate data in the email. I recommend checking both the mobile and desktop versions of your template, check all dynamic tags i.e. coupon code syntax (if applicable), the unsubscribe tag, any additional tags you added into the template. I also recommend testing by previewing the email to see if any more specific errors appear when you’re testing (that will help point us in a clearer direction).

We have a community thread that you may find helpful below:

and also a help center article that reviews the various syntax errors and reasons behind them.

I hope that’s helpful.

Badge +2

Hey Dov,

 

Thanks for the reply, when I go to generate a preview i get;

 

Your template contains invalid template tags or filters. Please fix them to create a preview.

 

This is just the standard Klaviyo back-in-stock email so not sure where to from here.

Userlevel 7
Badge +61

Hi @getlikeminded,

Thanks for your reply.

Got it. It’s quite unusual to see this error using the “out of the box” template. This may indicate a bug with the template. One last “quick fix” you can attempt is to try cloning the flow email (and try using the clone) or saving the email as a template and re-inserting it into your flow. In theory this wouldn’t change any of the tags but if this is a technical “hiccup” it may resolve it. If you’re still having trouble getting this to work “out of the box”, I recommend looking through the particular tags in your template with a support team member to help identify which tag(s) are causing the problem.

Thanks for being a community member.

 

Badge +2

Hi Dov,

 

I figured it out - I had Great News! {{product.title | strip_html}} is now available from {{shop.name}} in the email preview line, it didn’t like that 😂

Reply