Solved

First purchase anniversary flow not working

  • 18 April 2024
  • 8 replies
  • 57 views

Badge +1

I’m having an issue with the 1st purchase anniversary flow. I can’t figure out why the “conditional split” puts every customer in “Waiting”… 

I used Klaviyos template to create the flow.

It has been active for over a month and no email has been sent yet. Any ideas of why this might happen?

 

 

icon

Best answer by DavidV 22 April 2024, 07:07

View original

8 replies

Userlevel 6
Badge +24

Hi @Anita.UnalomeDesign,

Welcome to the Klaviyo community!

The reason it’s got this many waiting is because you have a 365 day wait step in the flow. So this first email won’t go out until 365 days after your first entered the flow. 

What is the full breakdown of the trigger here? Are you tagging a profile with the first purchase date in a different flow? 

Thanks
David

Badge +1

Thank you David! 

I just used the template available in Klaviyo… How can I edit it so it starts sending the emails now?

This is the trigger:



 

Badge +1

Should I set it to start Before the date property value?

 

Userlevel 6
Badge +24

Hi @Anita.UnalomeDesign,

Perfect - no you would use the On the date property value in this case. I’m assuming you’ve created the first purchase date in a different flow already.

Question for you, have you set the emails to live? Your original email cuts off right before the part where it shows the action status:

Do you have some profiles that have now hit their 1 year anniversary? You should be able to see this by looking up a profile that hit their anniversary in the last month, and clicking on “View messages”, then clicking scheduled at the top. This will show you when the email is scheduled to go out (in my case below, I was having a play around with the workings of this flow):

 

Badge +1

I do have a “thank you” email flow in place for people who purchase for the first time.

I have set both emails to “live” (they have been “live” for over a month).

I went in to see a few profiles, as you said, but in my case none of them have the anniversary email in the “scheduled” tab.

Any other idea of what might be going wrong? 😅 

Userlevel 6
Badge +24

Hi @Anita.UnalomeDesign,

Hmm that’s an odd one. Can you screenshot the flow you are using to assign the first purchase date to see if that’s where the issue is? 

Thanks
David

Badge +1

 

Userlevel 6
Badge +24

Whoops @Anita.UnalomeDesign - because you didn’t tag me I didn’t get notified of your screenshot so apologies for the delay in coming back.

That trigger should have a condition that you only apply this if this is their first order - otherwise it will update the date each time a customer places an order.

Because of the way the flow is set up, the first “Purchase Anniversary” reminder won’t go out until 12 months after the flow is created. You could manually backfill previous dates, but that’s why they’re all showing as pending. 

Hope that helps!

Thanks
David

Reply