Solved

Send Time Discrepancy

  • 31 May 2024
  • 1 reply
  • 34 views

Badge

I've encountered an issue with my custom report where the 'Send Time' occasionally does not match the actual send time displayed on the Campaign dashboard. Interestingly, this inconsistency does not occur across all emails; some reflect the correct time while others do not. Initially, I suspected this might be related to a time zone setting issue within my account, but the random nature of the correct and incorrect times has left me puzzled.

Has anyone experienced a similar issue or have insights on what might be causing this inconsistency? Any suggestions on how to resolve or troubleshoot this problem would be greatly appreciated.

Thank you!

icon

Best answer by Sujal 31 May 2024, 19:23

View original

1 reply

Userlevel 4
Badge +11

Hi @wsdev_td ,

The inconsistent send time display in your Klaviyo custom report is definitely puzzling. It's good you ruled out time zone settings as the culprit.  Here are some possibilities and troubleshooting steps:

1. Data Refresh Delays:

Custom reports might have a slight delay in refreshing data compared to the Campaign dashboard.
This could explain why some emails show accurate send times while others haven't updated yet.
Try waiting a bit for the report to refresh completely.


2. Custom Report Configuration:

Double-check your custom report configuration. Ensure the "Send Time" field is pulling data from the correct Klaviyo property.
Consider filtering your report to a specific timeframe and see if the inconsistency persists.


3. Klaviyo Support:

If the above steps don't resolve the issue, it might be a bug or specific configuration issue within your account. Contact Klaviyo support directly. They can investigate further based on your custom report setup and data sources.


Here are some additional insights for troubleshooting:

Compare Data with Individual Emails:

Open specific emails with reported discrepancies and check their individual "Sent At" time on the Klaviyo platform.
This can help confirm if the custom report data is genuinely inaccurate.

Reply